summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-05-26 16:01:54 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-05-26 16:01:54 +0000
commit7876ec6a1b97ac719869781db865f3c63f240071 (patch)
tree37d71e1d4c551a659fd807b37f73f001925d59e9 /media-plugins/mythvideo/mythvideo-0.22_p23469.ebuild
parentremove older versions (diff)
downloadgentoo-2-7876ec6a1b97ac719869781db865f3c63f240071.tar.gz
gentoo-2-7876ec6a1b97ac719869781db865f3c63f240071.tar.bz2
gentoo-2-7876ec6a1b97ac719869781db865f3c63f240071.zip
bump to the latest upstream 0.22 and remove older versions
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/mythvideo/mythvideo-0.22_p23469.ebuild')
-rw-r--r--media-plugins/mythvideo/mythvideo-0.22_p23469.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-plugins/mythvideo/mythvideo-0.22_p23469.ebuild b/media-plugins/mythvideo/mythvideo-0.22_p23469.ebuild
new file mode 100644
index 000000000000..bac1bead3842
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.22_p23469.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.22_p23469.ebuild,v 1.1 2010/05/26 16:01:54 cardoe Exp $
+
+EAPI=2
+
+inherit qt4 mythtv-plugins
+
+DESCRIPTION="Video player module for MythTV."
+IUSE="+jamu"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/URI
+ dev-perl/XML-Simple
+ sys-apps/eject
+ jamu? ( >=dev-python/imdbpy-3.8
+ >=dev-python/mysql-python-1.2.2
+ media-tv/mythtv[python] )"
+DEPEND=""
+
+src_install() {
+ mythtv-plugins_src_install
+
+ newinitd "${FILESDIR}"/mtd.init.d mtd
+
+ # correct permissions so MythVideo is actually usable
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.pl
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.py
+
+ # setup JAMU cron jobs
+ if use jamu; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/mythvideo.daily" mythvideo || die
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}/mythvideo.hourly" mythvideo || die
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/mythvideo.weekly" mythvideo || die
+ insinto /home/mythtv/.mythtv/
+ newins mythvideo/scripts/jamu-example.conf jamu.conf || die
+ fi
+}
+
+pkg_postinst() {
+ elog "MythVideo can use any media player to playback files if you"
+ elog "are *NOT* using Storage Groups. If you are using Storage"
+ elog "Groups, you *MUST* use the Internal player."
+ elog
+ elog "Otherwise, you can install mplayer, xine or any other video"
+ elog "player and use that instead by configuring the player to use."
+ elog "The default is 'Internal'."
+}