summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
commite4f208dd887e639fdac3f8a599c7c06cac41dde1 (patch)
tree59db30fcd642a5476b02fdfb3a3ff5fd7dc18f2f /media-plugins/mythweather
parentIntroduced CVS snapshot (diff)
downloadgentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.gz
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.bz2
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.zip
Version bump
Diffstat (limited to 'media-plugins/mythweather')
-rw-r--r--media-plugins/mythweather/ChangeLog7
-rw-r--r--media-plugins/mythweather/Manifest2
-rw-r--r--media-plugins/mythweather/files/digest-mythweather-0.141
-rw-r--r--media-plugins/mythweather/mythweather-0.14.ebuild39
4 files changed, 48 insertions, 1 deletions
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
index c653b4e6028f..c0da3fea282d 100644
--- a/media-plugins/mythweather/ChangeLog
+++ b/media-plugins/mythweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythweather
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.10 2004/01/15 18:05:22 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.11 2004/02/03 13:51:53 aliz Exp $
+
+*mythweather-0.14 (03 Feb 2004)
+
+ 03 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> mythweather-0.14.ebuild:
+ Version bump
15 Jan 2004; Max Kalika <max@gentoo.org> mythweather-0.13.ebuild:
Bump to stable x86.
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
index 4283f6f23abb..2c71896803d5 100644
--- a/media-plugins/mythweather/Manifest
+++ b/media-plugins/mythweather/Manifest
@@ -1,4 +1,5 @@
MD5 f6fbefd390920774fe46b900b7576480 mythweather-0.12.ebuild 979
+MD5 29b4e67c971035852ee6483fb1751703 mythweather-0.14.ebuild 980
MD5 066b932d813da05a4b9312ca84cc8772 mythweather-0.11.ebuild 972
MD5 f99dc2880b910d30925e69c4651d3269 mythweather-0.13.ebuild 979
MD5 3dd8c9ee1e865ce89336886174237a22 ChangeLog 1976
@@ -6,3 +7,4 @@ MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 6a31e4f0a87c61e3e7f0eb55dca2f03b files/digest-mythweather-0.11 69
MD5 916ba5d7844b0abae782627b8d1a21fe files/digest-mythweather-0.12 69
MD5 ea775d05013e97dd4c419804de2ed3b6 files/digest-mythweather-0.13 69
+MD5 1ab52ed2da7b97e38a6f31621371a400 files/digest-mythweather-0.14 69
diff --git a/media-plugins/mythweather/files/digest-mythweather-0.14 b/media-plugins/mythweather/files/digest-mythweather-0.14
new file mode 100644
index 000000000000..b95ce008f147
--- /dev/null
+++ b/media-plugins/mythweather/files/digest-mythweather-0.14
@@ -0,0 +1 @@
+MD5 061303237fd11d4348d52e169368114b mythweather-0.14.tar.bz2 831104
diff --git a/media-plugins/mythweather/mythweather-0.14.ebuild b/media-plugins/mythweather/mythweather-0.14.ebuild
new file mode 100644
index 000000000000..b459052d4261
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}