summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-06-14 08:44:13 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-06-14 08:44:13 +0000
commit9cbfd8d89b4b436bc3017d0d5a462b8490d4b41a (patch)
treea28ceb1495d35d3a8648e23d1ad3d388811448a4 /media-plugins/vdr-alcd/files
parentRemove connected routes after removing IP address from interface (#272696) an... (diff)
downloadgentoo-2-9cbfd8d89b4b436bc3017d0d5a462b8490d4b41a.tar.gz
gentoo-2-9cbfd8d89b4b436bc3017d0d5a462b8490d4b41a.tar.bz2
gentoo-2-9cbfd8d89b4b436bc3017d0d5a462b8490d4b41a.zip
Version bumped. Added upstream Helmut Auer to maintainers.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-alcd/files')
-rw-r--r--media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff22
-rw-r--r--media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff44
2 files changed, 66 insertions, 0 deletions
diff --git a/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff
new file mode 100644
index 000000000000..a4465220534a
--- /dev/null
+++ b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-gcc-4.4.diff
@@ -0,0 +1,22 @@
+Index: alcd-1.5.1/thread.c
+===================================================================
+--- alcd-1.5.1.orig/thread.c
++++ alcd-1.5.1/thread.c
+@@ -104,7 +104,7 @@ void cLCD::SetText( const char *szText )
+ // only proceed, if valid data
+ if( szText != NULL && strlen( szText ) > 0 ) {
+ // set channel name
+- char *delim = strchr( szText, '|' );
++ const char *delim = strchr( szText, '|' );
+ if( delim ) {
+ char buffer[ BUFSIZE ];
+ int sLen = ( delim - szText ) >= BUFSIZE ? BUFSIZE : ( delim - szText );
+@@ -420,7 +420,7 @@ void cLCD::Replaying( const cControl *co
+ if( szFileName[i] == ')' )
+ strncpy( (char *)szReplayMode, szFileName + 8, i - 8 );
+ }
+- char *p = strstr( szFileName + i, " : " );
++ const char *p = strstr( szFileName + i, " : " );
+ if( p )
+ strncpy( szTemp, p + 3, sizeof(szTemp ));
+ else
diff --git a/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff
new file mode 100644
index 000000000000..ea1488e40b0f
--- /dev/null
+++ b/media-plugins/vdr-alcd/files/vdr-alcd-1.5.1-makefile-cleanup.diff
@@ -0,0 +1,44 @@
+Index: alcd-1.5.1/Makefile
+===================================================================
+--- alcd-1.5.1.orig/Makefile
++++ alcd-1.5.1/Makefile
+@@ -23,8 +23,8 @@ VDRINC = $(VDRDIR)/include
+ LIBDIR = ../../lib
+ TMPDIR = /tmp
+
+-CXX = g++
+-CXXFLAGS = -O2 -Wall -Woverloaded-virtual -D_GNU_SOURCE
++CXX ?= g++
++CXXFLAGS ?= -fPIC -O2 -Wall -Woverloaded-virtual
+
+ -include $(VDRDIR)/Make.config
+
+@@ -41,6 +41,8 @@ PACKAGE = vdr-$(ARCHIVE)
+
+ INCLUDES = -I$(VDRDIR)/include
+
++DEFINES += -D_GNU_SOURCE
++
+ ### Allow user defined options to overwrite defaults:
+
+ DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+@@ -53,6 +55,10 @@ endif
+
+ OBJS = $(PLUGIN).o lcd.o thread.o setup.o
+
++### The main target:
++
++all: libvdr-$(PLUGIN).so i18n
++
+ ### Target directory for afp-tool binary
+
+ PREFIX = /usr
+@@ -100,8 +106,6 @@ i18n: $(I18Nmsgs)
+
+ ### Targets:
+
+-all: libvdr-$(PLUGIN).so i18n
+-
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
+ @cp $@ $(LIBDIR)/$@.$(APIVERSION)