summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-10-20 18:02:23 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-10-20 18:02:23 +0000
commit37f9b793872ea97f1dc96374c57145722e9ca2ac (patch)
tree8bb2c767c48c019ccb29e8daf23381264783e147 /media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
parentAdd cssselect dependency for bug #439058 (use --force since we need to do a s... (diff)
downloadgentoo-2-37f9b793872ea97f1dc96374c57145722e9ca2ac.tar.gz
gentoo-2-37f9b793872ea97f1dc96374c57145722e9ca2ac.tar.bz2
gentoo-2-37f9b793872ea97f1dc96374c57145722e9ca2ac.zip
vdr-plugin-2.eclass, fixed append string
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild')
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..b82ad4783a05
--- /dev/null
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild,v 1.1 2012/10/20 18:02:23 hd_brummy Exp $
+
+EAPI="4"
+
+VERSION="880" # every bump, new version
+
+inherit vdr-plugin-2 flag-o-matic
+
+DESCRIPTION="VDR plugin: Show another channel in the OSD"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-osdpip"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6.0_p2-r5
+ >=media-libs/libmpeg2-0.5.1
+ >=virtual/ffmpeg-0.6.90"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # UINT64_C is needed by ffmpeg headers
+ append-cxxflags -D__STDC_CONSTANT_MACROS
+}