summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2013-03-31 13:06:59 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2013-03-31 13:06:59 +0000
commit02bfaa7cfadfc6c5eeecac88972df26dc59ab5a6 (patch)
treeae7ec7b576e422074d874ba9384cb4d4aabacc6d /media-plugins/vdr-permashift
parentGNOME2_LA_PUNT=yes still needed with USE 'sendto' (diff)
downloadgentoo-2-02bfaa7cfadfc6c5eeecac88972df26dc59ab5a6.tar.gz
gentoo-2-02bfaa7cfadfc6c5eeecac88972df26dc59ab5a6.tar.bz2
gentoo-2-02bfaa7cfadfc6c5eeecac88972df26dc59ab5a6.zip
bump
(Portage version: 2.1.11.50/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins/vdr-permashift')
-rw-r--r--media-plugins/vdr-permashift/ChangeLog10
-rw-r--r--media-plugins/vdr-permashift/files/permashift.mk125
-rw-r--r--media-plugins/vdr-permashift/metadata.xml12
-rw-r--r--media-plugins/vdr-permashift/vdr-permashift-0.5.1.ebuild27
4 files changed, 174 insertions, 0 deletions
diff --git a/media-plugins/vdr-permashift/ChangeLog b/media-plugins/vdr-permashift/ChangeLog
new file mode 100644
index 000000000000..e6ac827e0db4
--- /dev/null
+++ b/media-plugins/vdr-permashift/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-plugins/vdr-permashift
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-permashift/ChangeLog,v 1.1 2013/03/31 13:06:59 hd_brummy Exp $
+
+*vdr-permashift-0.5.1 (31 Mar 2013)
+
+ 31 Mar 2013; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +vdr-permashift-0.5.1.ebuild, +files/permashift.mk, +metadata.xml:
+ bump
+
diff --git a/media-plugins/vdr-permashift/files/permashift.mk b/media-plugins/vdr-permashift/files/permashift.mk
new file mode 100644
index 000000000000..68e3f4b6e311
--- /dev/null
+++ b/media-plugins/vdr-permashift/files/permashift.mk
@@ -0,0 +1,125 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id: permashift.mk,v 1.1 2013/03/31 13:06:59 hd_brummy Exp $
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+# add the name of the plugin, next edit the OBJS line,
+PLUGIN = permashift
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+INCLUDES +=
+
+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o
+
+### The main target:
+
+all: $(SOFILE)
+# i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<#
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib
+# install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-permashift/metadata.xml b/media-plugins/vdr-permashift/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-permashift/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-permashift/vdr-permashift-0.5.1.ebuild b/media-plugins/vdr-permashift/vdr-permashift-0.5.1.ebuild
new file mode 100644
index 000000000000..0902f19e6e19
--- /dev/null
+++ b/media-plugins/vdr-permashift/vdr-permashift-0.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-permashift/vdr-permashift-0.5.1.ebuild,v 1.1 2013/03/31 13:06:59 hd_brummy Exp $
+
+EAPI="5"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: permanent timeshift by recording live TV on hard disk"
+HOMEPAGE="http://ein-eike.de/vdr-plugin-permashift-english/"
+SRC_URI="http://ein-eike.de/wordpress/wp-content/uploads/2013/01/permashift-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.38[permashift]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${VDRPLUGIN}"
+
+src_prepare() {
+ cp "${FILESDIR}/${VDRPLUGIN}.mk" "${S}"/Makefile
+
+ vdr-plugin-2_src_prepare
+}