summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2007-02-16 12:26:37 +0000
committerSimon Stelling <blubb@gentoo.org>2007-02-16 12:26:37 +0000
commit588f266c6d52284bad1cd6ec736730c47f358da9 (patch)
tree6d5150497495dbec4593134278dca9cfbf29f159 /media-plugins/vdr-softdevice
parentdepend on >=portage-2.1.2 on amd64 to make sure the assembler USE flags are u... (diff)
downloadgentoo-2-588f266c6d52284bad1cd6ec736730c47f358da9.tar.gz
gentoo-2-588f266c6d52284bad1cd6ec736730c47f358da9.tar.bz2
gentoo-2-588f266c6d52284bad1cd6ec736730c47f358da9.zip
depend on >=portage-2.1.2 on amd64 to make sure the assembler USE flags are unmasked
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-plugins/vdr-softdevice')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog7
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061217.ebuild22
2 files changed, 16 insertions, 13 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index 57578311a2b4..494b763c1654 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.33 2007/01/05 16:51:49 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.34 2007/02/16 12:26:37 blubb Exp $
+
+ 16 Feb 2007; Simon Stelling <blubb@gentoo.org>
+ vdr-softdevice-0.3.1.20061217.ebuild:
+ depend on >=portage-2.1.2 on amd64 to make sure the assembler USE flags are
+ unmasked
05 Jan 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-softdevice-0.3.0-r1.ebuild, vdr-softdevice-0.3.1-r2.ebuild,
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061217.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061217.ebuild
index 9423615aa10e..54f2a52dd2ec 100644
--- a/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061217.ebuild
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061217.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061217.ebuild,v 1.2 2007/01/05 16:51:49 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061217.ebuild,v 1.3 2007/02/16 12:26:37 blubb Exp $
inherit vdr-plugin
@@ -43,7 +43,9 @@ DEPEND="${RDEPEND}
) )
fbcon? ( sys-kernel/linux-headers )
dev-util/pkgconfig"
-
+# Make sure the assembler USE flags are unmasked on amd64
+# Remove this once default-linux/amd64/2006.1 is deprecated
+DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
PATCHES="
${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
@@ -93,17 +95,13 @@ src_compile() {
use fbcon || MYOPTS="${MYOPTS} --disable-fb"
use directfb || MYOPTS="${MYOPTS} --disable-dfb"
- # MMX-Support
- # hardcode mmx for amd64 - do not disable even without use-flag
- if ! use amd64; then
- use mmx || MYOPTS="${MYOPTS} --disable-mmx"
- use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+ use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+ use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
- if use !mmx && use !mmxext; then
- ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
- ewarn 'Please enable at least one of these two use-flags.'
- die "${PN}"' does not compile with USE="-mmx -mmxext".'
- fi
+ if use !mmx && use !mmxext; then
+ ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
+ ewarn 'Please enable at least one of these two use-flags.'
+ die "${PN}"' does not compile with USE="-mmx -mmxext".'
fi
use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"