summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-02-13 20:59:01 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-02-13 20:59:01 +0000
commit8f68da66e7619b6301ceb7afd5dbafcaba50aca4 (patch)
treeae910167c8030861750f3468b86af92ed8a588c5 /media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
parent- comment out bash3 syntax till bash3 goes stable (diff)
downloadgentoo-2-8f68da66e7619b6301ceb7afd5dbafcaba50aca4.tar.gz
gentoo-2-8f68da66e7619b6301ceb7afd5dbafcaba50aca4.tar.bz2
gentoo-2-8f68da66e7619b6301ceb7afd5dbafcaba50aca4.zip
Fix bad reference to OSS headerfile. Closes bug #81864.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild')
-rw-r--r--media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
index 7003a242a9a9..837e18789ef0 100644
--- a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
+++ b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
@@ -1,22 +1,30 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild,v 1.2 2005/02/12 02:58:43 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild,v 1.3 2005/02/13 20:59:01 eradicator Exp $
-IUSE="ipv6"
+IUSE="ipv6 oss"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
DEPEND=">=media-sound/xmms-1.2.10"
-PATCH_VER="2.2.2"
-
PLUGIN_PATH="Input/cdaudio"
+PATCH_VER="2.2.2"
M4_VER="1.0"
inherit xmms-plugin
+src_unpack() {
+ xmms-plugin_src_unpack
+
+ cd ${S}/${PLUGIN_PATH}
+ cp ${S}/Output/OSS/soundcard.h .
+
+ sed -i 's:<Output/OSS/soundcard.h>:"soundcard.h":' *.{h,c}
+}
+
src_compile() {
- myconf="${myconf} --enable-cdaudio $(use_enable ipv6)"
+ myconf="${myconf} --enable-cdaudio $(use_enable ipv6) $(use_enable oss)"
xmms-plugin_src_compile
}