summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-08-10 23:48:31 +0000
committerMart Raudsepp <leio@gentoo.org>2011-08-10 23:48:31 +0000
commit235a15368969d1d2bac626e4109d21f59fe0956d (patch)
tree025db50fccf13d95861335529568373175e1c19d /media-plugins
parentFix LDFLAGS not being respected (diff)
downloadgentoo-2-235a15368969d1d2bac626e4109d21f59fe0956d.tar.gz
gentoo-2-235a15368969d1d2bac626e4109d21f59fe0956d.tar.bz2
gentoo-2-235a15368969d1d2bac626e4109d21f59fe0956d.zip
Version bump. Updated to use libav-0.7.1 instead of ffmpeg (including new codecs) - for now still bundled version though, not system. Timestamp tracking fixes, which fixes various problematic videos that ran at wrong speed or just not work. Multi-threaded decoding support associated with new libav, but disabled by default because it is too unstable still.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-ffmpeg/ChangeLog12
-rw-r--r--media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.12.ebuild44
2 files changed, 55 insertions, 1 deletions
diff --git a/media-plugins/gst-plugins-ffmpeg/ChangeLog b/media-plugins/gst-plugins-ffmpeg/ChangeLog
index 07c1f7c5ae95..cac95a0a9932 100644
--- a/media-plugins/gst-plugins-ffmpeg/ChangeLog
+++ b/media-plugins/gst-plugins-ffmpeg/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-plugins/gst-plugins-ffmpeg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/ChangeLog,v 1.129 2011/07/25 18:07:10 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/ChangeLog,v 1.130 2011/08/10 23:48:31 leio Exp $
+
+*gst-plugins-ffmpeg-0.10.12 (10 Aug 2011)
+
+ 10 Aug 2011; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-ffmpeg-0.10.12.ebuild:
+ Version bump. Updated to use libav-0.7.1 instead of ffmpeg (including new
+ codecs) - for now still bundled version though, not system. Timestamp
+ tracking fixes, which fixes various problematic videos that ran at wrong
+ speed or just not work. Multi-threaded decoding support associated with
+ new libav, but disabled by default because it is too unstable still.
25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org>
gst-plugins-ffmpeg-0.10.11-r1.ebuild:
diff --git a/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.12.ebuild b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.12.ebuild
new file mode 100644
index 000000000000..60fd0c8e7381
--- /dev/null
+++ b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.12.ebuild,v 1.1 2011/08/10 23:48:31 leio Exp $
+
+EAPI=1
+
+inherit flag-o-matic eutils base
+
+PD=${FILESDIR}/${PV}
+MY_PN=${PN/-plugins}
+MY_P=${MY_PN}-${PV}
+
+# Create a major/minor combo for SLOT
+PVP=(${PV//[-\._]/ })
+SLOT=${PVP[0]}.${PVP[1]}
+#SLOT=0.10
+
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="http://gstreamer.freedesktop.org/modules/gst-ffmpeg.html"
+SRC_URI="http://gstreamer.freedesktop.org/src/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+orc"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=media-libs/gstreamer-0.10.31
+ >=media-libs/gst-plugins-base-0.10.31
+ orc? ( >=dev-lang/orc-0.4.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+
+ econf $(use_enable orc)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}