summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-10 19:24:33 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-10 19:24:33 +0000
commit5966753fc933c57afbe62910373079365d288eb5 (patch)
tree380efe81471e81b38032b5c614a41d8e25ee55cd /media-plugins
parentEnable multilib support, bug #493176. (diff)
downloadgentoo-2-5966753fc933c57afbe62910373079365d288eb5.tar.gz
gentoo-2-5966753fc933c57afbe62910373079365d288eb5.tar.bz2
gentoo-2-5966753fc933c57afbe62910373079365d288eb5.zip
Enable multilib support, bug #493176.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-x/ChangeLog10
-rw-r--r--media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/media-plugins/gst-plugins-x/ChangeLog b/media-plugins/gst-plugins-x/ChangeLog
index 07346dcefda6..baf8fa9a3375 100644
--- a/media-plugins/gst-plugins-x/ChangeLog
+++ b/media-plugins/gst-plugins-x/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gst-plugins-x
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-x/ChangeLog,v 1.141 2013/03/05 22:03:17 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-x/ChangeLog,v 1.142 2014/06/10 19:24:33 mgorny Exp $
+
+*gst-plugins-x-0.10.36-r1 (10 Jun 2014)
+
+ 10 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +gst-plugins-x-0.10.36-r1.ebuild:
+ Enable multilib support, bug #493176.
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-gst-plugins-x-0.10.35.ebuild, -gst-plugins-x-0.10.35-r1.ebuild:
diff --git a/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild
new file mode 100644
index 000000000000..fd509304a812
--- /dev/null
+++ b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild,v 1.1 2014/06/10 19:24:33 mgorny Exp $
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-base
+inherit gstreamer
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/xextproto[${MULTILIB_USEDEP}]"
+
+# xshm is a compile time option of ximage, which is in libXext
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"
+
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+
+ gstreamer_system_link \
+ gst-libs/gst/video:gstreamer-video \
+ gst-libs/gst/interfaces:gstreamer-interfaces
+}