summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-10-01 03:36:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-10-01 03:36:36 +0000
commit5aa4f2c1d9eeefd2ec37132bd76742823a7b3866 (patch)
treeb06225c78a747be01f215ddd05fa44966edf1e2e /media-plugins
parentVersion bump. Fixes Qt-4.7 compilation (bug #338973) (diff)
downloadgentoo-2-5aa4f2c1d9eeefd2ec37132bd76742823a7b3866.tar.gz
gentoo-2-5aa4f2c1d9eeefd2ec37132bd76742823a7b3866.tar.bz2
gentoo-2-5aa4f2c1d9eeefd2ec37132bd76742823a7b3866.zip
Version bump. Fix compilation with Qt-4.7
(Portage version: 2.1.9.12/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythvideo/ChangeLog8
-rw-r--r--media-plugins/mythvideo/mythvideo-0.23.1_p26407.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
index cf5f92517269..94a8e45d61fd 100644
--- a/media-plugins/mythvideo/ChangeLog
+++ b/media-plugins/mythvideo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythvideo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.93 2010/08/02 04:49:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.94 2010/10/01 03:36:36 cardoe Exp $
+
+*mythvideo-0.23.1_p26407 (01 Oct 2010)
+
+ 01 Oct 2010; Doug Goldstein <cardoe@gentoo.org>
+ +mythvideo-0.23.1_p26407.ebuild:
+ Version bump. Fix compilation with Qt-4.7
*mythvideo-0.23.1_p25496 (02 Aug 2010)
diff --git a/media-plugins/mythvideo/mythvideo-0.23.1_p26407.ebuild b/media-plugins/mythvideo/mythvideo-0.23.1_p26407.ebuild
new file mode 100644
index 000000000000..333181202787
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.23.1_p26407.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.23.1_p26407.ebuild,v 1.1 2010/10/01 03:36:36 cardoe Exp $
+
+EAPI=2
+
+inherit qt4 mythtv-plugins
+
+DESCRIPTION="Video player module for MythTV."
+IUSE="+jamu"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/URI
+ dev-perl/XML-Simple
+ sys-apps/eject
+ jamu? ( >=dev-python/imdbpy-3.8
+ dev-python/imaging
+ >=dev-python/mysql-python-1.2.2
+ media-tv/mythtv[python] )"
+DEPEND=""
+
+src_install() {
+ mythtv-plugins_src_install
+
+ newinitd "${FILESDIR}"/mtd.init.d mtd
+
+ # correct permissions so MythVideo is actually usable
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.pl
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.py
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*/*.pl
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*/*.py
+
+ # setup JAMU cron jobs
+ if use jamu; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/mythvideo.daily" mythvideo || die
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}/mythvideo.hourly" mythvideo || die
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/mythvideo.weekly" mythvideo || die
+ insinto /home/mythtv/.mythtv/
+ newins mythvideo/scripts/jamu-example.conf jamu.conf || die
+ fi
+}
+
+pkg_postinst() {
+ elog "MythVideo can use any media player to playback files if you"
+ elog "are *NOT* using Storage Groups. If you are using Storage"
+ elog "Groups, you *MUST* use the Internal player."
+ elog
+ elog "Otherwise, you can install mplayer, xine or any other video"
+ elog "player and use that instead by configuring the player to use."
+ elog "The default is 'Internal'."
+}