summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-09-12 11:15:53 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-09-12 11:15:53 +0000
commitb7bb684a126e1dd86ce959f58b277941679996bf (patch)
tree195ef0db6f506e169cfd2b44a10f30924d01f60b /media-radio/ibp/ibp-0.21.ebuild
parentVersion bump (diff)
downloadgentoo-2-b7bb684a126e1dd86ce959f58b277941679996bf.tar.gz
gentoo-2-b7bb684a126e1dd86ce959f58b277941679996bf.tar.bz2
gentoo-2-b7bb684a126e1dd86ce959f58b277941679996bf.zip
Initial portage version. Moved from sunrise. Bug #237579
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-radio/ibp/ibp-0.21.ebuild')
-rw-r--r--media-radio/ibp/ibp-0.21.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-radio/ibp/ibp-0.21.ebuild b/media-radio/ibp/ibp-0.21.ebuild
new file mode 100644
index 000000000000..341995878ea1
--- /dev/null
+++ b/media-radio/ibp/ibp-0.21.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ibp/ibp-0.21.ebuild,v 1.1 2010/09/12 11:15:53 tomjbe Exp $
+
+DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
+HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}.html"
+SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-misc/imake )"
+
+src_compile() {
+ if ( use X ) ;then
+ xmkmf || die " xmkmf failed"
+ fi
+ emake || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+}