summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-08-27 18:37:40 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-08-27 18:37:40 +0000
commit8360527f94afdaee40678a8be6daee76cee2bd4b (patch)
treebcf7f5e40eacdeb9d91c49959949b1463719873e /media-radio
parentalpha/ia64/s390/sh/sparc stable wrt #418855 (diff)
downloadgentoo-2-8360527f94afdaee40678a8be6daee76cee2bd4b.tar.gz
gentoo-2-8360527f94afdaee40678a8be6daee76cee2bd4b.tar.bz2
gentoo-2-8360527f94afdaee40678a8be6daee76cee2bd4b.zip
Do not builtin shapelib if sci-libs/shapelib is not installed. Build without shapelib support instead. (bug #430704). Thanks Diego.
(Portage version: 2.1.11.11/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xastir/ChangeLog7
-rw-r--r--media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff52
-rw-r--r--media-radio/xastir/xastir-2.0.0-r2.ebuild9
3 files changed, 64 insertions, 4 deletions
diff --git a/media-radio/xastir/ChangeLog b/media-radio/xastir/ChangeLog
index acad286796ec..39a8b28b9036 100644
--- a/media-radio/xastir/ChangeLog
+++ b/media-radio/xastir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/xastir
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.23 2012/06/18 09:04:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.24 2012/08/27 18:37:39 tomjbe Exp $
+
+ 27 Aug 2012; Thomas Beierlein <tomjbe@gentoo.org> xastir-2.0.0-r2.ebuild,
+ +files/xastir-2.0.0-no-builtin-shapelib.diff:
+ Do not use builtin shapelib if sci-libs/shapelib is not installed. Build
+ without shapelib support instead. (bug #430704). Thanks Diego.
18 Jun 2012; Agostino Sarubbo <ago@gentoo.org> -xastir-1.9.8.ebuild:
Remove old
diff --git a/media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff b/media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff
new file mode 100644
index 000000000000..919b6aa01d64
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff
@@ -0,0 +1,52 @@
+# Do not use builtin bundled shapelib if sci-libs/shapelib is not
+# installed. Drop shapelib support instead (bug #430704)
+--- configure.ac.orig 2012-08-27 20:17:30.000000000 +0200
++++ configure.ac 2012-08-27 20:19:32.000000000 +0200
+@@ -338,24 +338,14 @@
+
+ # Check for Shapelib
+ use_shapelib=yes
+-force_internal_shapelib=no
+ shapelib_desired=yes
+ LIBSHP=""
+ SUBSHP=""
+-AC_ARG_WITH(internal-shapelib,[ --with-internal-shapelib Force use of internal shapelib library.],force_internal_shapelib=$withval)
+ AC_ARG_WITH(shapelib,[ --without-shapelib Disable shapelib features.],shapelib_desired=$withval)
+ if test "${shapelib_desired}" = "no"; then
+ use_shapelib=no
+- force_internal_shapelib=no
+ fi
+-if test "${force_internal_shapelib}" = "yes"; then
+- AC_MSG_WARN([***************************************************************** ])
+- AC_MSG_WARN([Internal Shapelib library has been forced. ])
+- AC_MSG_WARN([***************************************************************** ])
+- # Temporary setting to get into if block below
+- use_shapelib=no
+-fi
+-if test "${shapelib_desired}" = "yes" -a "${force_internal_shapelib}" = "no"; then
++if test "${shapelib_desired}" = "yes" ; then
+ use_shapelib=no
+ AC_CHECK_HEADERS(shapefil.h libshp/shapefil.h, [AC_CHECK_LIB(shp, DBFOpen, use_shapelib=yes
+ LIBS="$LIBS -lshp"
+@@ -364,21 +354,6 @@
+ AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
+ break)])
+ fi
+-if test "${shapelib_desired}" = "yes" -a "${use_shapelib}" = "no"; then
+- AC_MSG_WARN([**************************************************************** ])
+- AC_MSG_WARN([Your system does not have shapelib installed. Using an internal ])
+- AC_MSG_WARN([version. This may lead to a larger filesize for the executable. ])
+- AC_MSG_WARN([Install shapelib on your system to eliminate this warning. ])
+- AC_MSG_WARN([**************************************************************** ])
+- LIBSHP="-Lshapelib -lshape"
+- CPPFLAGS="-I\$(top_srcdir)/src/shapelib $CPPFLAGS"
+- SUBSHP="shapelib"
+- use_shapelib=yes
+- force_internal_shapelib=yes
+- AC_DEFINE(HAVE_DBFGETFIELDINDEX, , Define to 1 if your `shp' library has DBFGetFieldIndex. )
+- AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
+- AC_DEFINE(HAVE_SHAPEFIL_H, , Define to 1 if you have the `shapefil.h' header. )
+-fi
+ AC_SUBST(SUBSHP)
+ AC_SUBST(LIBSHP)
+
diff --git a/media-radio/xastir/xastir-2.0.0-r2.ebuild b/media-radio/xastir/xastir-2.0.0-r2.ebuild
index 6e0ad546e1a8..a3054a92bb50 100644
--- a/media-radio/xastir/xastir-2.0.0-r2.ebuild
+++ b/media-radio/xastir/xastir-2.0.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/xastir-2.0.0-r2.ebuild,v 1.2 2012/06/04 17:51:52 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/xastir-2.0.0-r2.ebuild,v 1.3 2012/08/27 18:37:40 tomjbe Exp $
EAPI=2
inherit autotools eutils
@@ -43,12 +43,15 @@ src_prepare() {
# fix breakage with >=sci-libs/proj-4.8
epatch "${FILESDIR}"/${P}-proj48.diff
+ # do not use builtin shapelib if sci-libs/shapelib is not installed
+ # instead build without shapelib support (bug #430704)
+ epatch "${FILESDIR}"/${P}-no-builtin-shapelib.diff
+
eautoreconf
}
src_configure() {
- econf --without-graphicsmagick \
- --with-pcre \
+ econf --with-pcre \
--with-shapelib \
--with-dbfawk \
--without-ax25 \