summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-02-10 15:12:27 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-02-10 15:12:27 +0000
commitde31559720277fcac4d3248f1dd0b3fdc76baf8e (patch)
treed4236cf7c4edee1fa2a9a1e06055eabf538d96d8 /media-radio
parentAdded -pool.patch, fixes broken test, fixes Bug #451610 (diff)
downloadgentoo-2-de31559720277fcac4d3248f1dd0b3fdc76baf8e.tar.gz
gentoo-2-de31559720277fcac4d3248f1dd0b3fdc76baf8e.tar.bz2
gentoo-2-de31559720277fcac4d3248f1dd0b3fdc76baf8e.zip
Add further missing includes
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/unixcw/ChangeLog6
-rw-r--r--media-radio/unixcw/files/unixcw-3.2.0-pulseaudio.patch12
-rw-r--r--media-radio/unixcw/unixcw-3.2.0.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/media-radio/unixcw/ChangeLog b/media-radio/unixcw/ChangeLog
index fc15078bfe3e..c414e6098d90 100644
--- a/media-radio/unixcw/ChangeLog
+++ b/media-radio/unixcw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-radio/unixcw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.9 2013/02/09 17:41:52 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.10 2013/02/10 15:12:27 tomjbe Exp $
+
+ 10 Feb 2013; Thomas Beierlein <tomjbe@gentoo.org> unixcw-3.2.0.ebuild,
+ +files/unixcw-3.2.0-pulseaudio.patch:
+ Add further missing includes
09 Feb 2013; Thomas Beierlein <tomjbe@gentoo.org> unixcw-3.2.0.ebuild,
+files/unixcw-3.2.0-console.patch:
diff --git a/media-radio/unixcw/files/unixcw-3.2.0-pulseaudio.patch b/media-radio/unixcw/files/unixcw-3.2.0-pulseaudio.patch
new file mode 100644
index 000000000000..a0dffd67de34
--- /dev/null
+++ b/media-radio/unixcw/files/unixcw-3.2.0-pulseaudio.patch
@@ -0,0 +1,12 @@
+--- src/libcw/libcw_pa.c.orig 2013-01-03 22:09:38.000000000 +0000
++++ src/libcw/libcw_pa.c 2013-02-10 14:29:51.000000000 +0000
+@@ -30,7 +30,8 @@
+ #include <stdlib.h>
+ #include <stdbool.h>
+ #include <dlfcn.h> /* dlopen() and related symbols */
+-
++#include <string.h>
++#include <assert.h>
+
+ #include "libcw.h"
+ #include "libcw_pa.h"
diff --git a/media-radio/unixcw/unixcw-3.2.0.ebuild b/media-radio/unixcw/unixcw-3.2.0.ebuild
index 67300565c2d3..8a2895152b93 100644
--- a/media-radio/unixcw/unixcw-3.2.0.ebuild
+++ b/media-radio/unixcw/unixcw-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.2.0.ebuild,v 1.2 2013/02/09 17:41:52 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.2.0.ebuild,v 1.3 2013/02/10 15:12:27 tomjbe Exp $
EAPI=4
@@ -25,7 +25,8 @@ DEPEND="${RDEPEND}
!<=app-misc/cw-1.0.16-r1"
src_prepare() {
- epatch "${FILESDIR}"/${P}-console.patch
+ epatch "${FILESDIR}"/${P}-console.patch \
+ "${FILESDIR}"/${P}-pulseaudio.patch
append-cflags -std=gnu99
# add path to qt4 libs