summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-14 03:49:58 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-14 03:49:58 +0000
commit4813085ccfe9fcb9250db790db245490b659958f (patch)
tree738182fcc83a2c3e4534d1b1827321117827fefb /media-sound/abcmidi
parentBump (diff)
downloadgentoo-2-4813085ccfe9fcb9250db790db245490b659958f.tar.gz
gentoo-2-4813085ccfe9fcb9250db790db245490b659958f.tar.bz2
gentoo-2-4813085ccfe9fcb9250db790db245490b659958f.zip
Version bump.
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/abcmidi')
-rw-r--r--media-sound/abcmidi/ChangeLog9
-rw-r--r--media-sound/abcmidi/abcmidi-2012.12.25.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index 1bd3c9fdeb1f..be1b1a35ff62 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.27 2012/12/24 02:32:19 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.28 2013/01/14 03:49:58 radhermit Exp $
+
+*abcmidi-2012.12.25 (14 Jan 2013)
+
+ 14 Jan 2013; Tim Harder <radhermit@gentoo.org> +abcmidi-2012.12.25.ebuild:
+ Version bump.
*abcmidi-2012.12.12 (24 Dec 2012)
diff --git a/media-sound/abcmidi/abcmidi-2012.12.25.ebuild b/media-sound/abcmidi/abcmidi-2012.12.25.ebuild
new file mode 100644
index 000000000000..9d9dc5b991eb
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2012.12.25.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2012.12.25.ebuild,v 1.1 2013/01/14 03:49:58 radhermit Exp $
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i -e "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}