summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-19 00:41:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-19 00:41:20 +0000
commit63ad0fd99b46064e851ae095cfdb418224b5af04 (patch)
tree5e1ef973d0e194defa9ed1ab14c0c09090a258d8 /media-sound/amarok
parentStable for HPPA (bug #147751). (diff)
downloadgentoo-2-63ad0fd99b46064e851ae095cfdb418224b5af04.tar.gz
gentoo-2-63ad0fd99b46064e851ae095cfdb418224b5af04.tar.bz2
gentoo-2-63ad0fd99b46064e851ae095cfdb418224b5af04.zip
Add patch to fix building with newer versions of libgpod; closes bug #162725; thanks to Alessio Cassiba for reporting, and Olivier Crete for pointing out the problem.
(Portage version: 2.1.2)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog10
-rw-r--r--media-sound/amarok/amarok-1.4.4-r3.ebuild7
-rw-r--r--media-sound/amarok/files/amarok-1.4.4+libgpod-0.4.0.patch80
3 files changed, 92 insertions, 5 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index dbfd24146eb3..2ac06c4839fb 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.193 2006/12/31 12:56:45 flameeyes Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.194 2007/01/19 00:41:20 flameeyes Exp $
+
+ 19 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/amarok-1.4.4+libgpod-0.4.0.patch, amarok-1.4.4-r3.ebuild:
+ Add patch to fix building with newer versions of libgpod; closes bug
+ #162725; thanks to Alessio Cassiba for reporting, and Olivier Crete for
+ pointing out the problem.
31 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> amarok-9999.ebuild:
As the current SVN version requires a newer libmtp, make the 9999 ebuild
diff --git a/media-sound/amarok/amarok-1.4.4-r3.ebuild b/media-sound/amarok/amarok-1.4.4-r3.ebuild
index 8d500ab14253..baa27b00b1b2 100644
--- a/media-sound/amarok/amarok-1.4.4-r3.ebuild
+++ b/media-sound/amarok/amarok-1.4.4-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.4-r3.ebuild,v 1.5 2006/12/26 14:49:34 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.4-r3.ebuild,v 1.6 2007/01/19 00:41:20 flameeyes Exp $
LANGS="af ar az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it
ja ka km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw sk sl sq sr sr@Latn sv ta tg
@@ -50,7 +50,8 @@ DEPEND="${RDEPEND}"
need-kde 3.3
-PATCHES="${WORKDIR}/${P}-gentoo/*.patch"
+PATCHES="${WORKDIR}/${P}-gentoo/*.patch
+ ${FILESDIR}/${P}+libgpod-0.4.0.patch"
src_compile() {
# Extra, unsupported engines are forcefully disabled.
diff --git a/media-sound/amarok/files/amarok-1.4.4+libgpod-0.4.0.patch b/media-sound/amarok/files/amarok-1.4.4+libgpod-0.4.0.patch
new file mode 100644
index 000000000000..4109649f6934
--- /dev/null
+++ b/media-sound/amarok/files/amarok-1.4.4+libgpod-0.4.0.patch
@@ -0,0 +1,80 @@
+Index: src/mediadevice/ipod/ipodmediadevice.cpp
+===================================================================
+--- amarok-svn/amarok/src/mediadevice/ipod/ipodmediadevice.cpp (revision 605590)
++++ amarok-svn/amarok/src/mediadevice/ipod/ipodmediadevice.cpp (revision 605591)
+@@ -302,7 +302,11 @@
+ track->genre = g_strdup( metaBundle.genre()->utf8() );
+
+
++#ifdef HAVE_ITDB_MEDIATYPE
++ track->mediatype = 0x01; // for audio
++#else
+ track->unk208 = 0x01; // for audio
++#endif
+ if(type=="wav")
+ {
+ track->filetype = g_strdup( "wav" );
+@@ -323,7 +327,11 @@
+ #else
+ track->flag3 |= 0x01; // remember current position in track
+ #endif
++#ifdef HAVE_ITDB_MEDIATYPE
++ track->mediatype = 0x08; // for audiobooks
++#else
+ track->unk208 = 0x08; // for audiobooks
++#endif
+ }
+ else if(type=="m4v" || type=="mp4v" || type=="mov" || type=="mpg" || type=="mp4")
+ {
+@@ -331,7 +339,11 @@
+ #ifdef HAVE_ITDB_SKIP_SHUFFLE_FLAG
+ track->movie_flag = 0x01; // for videos
+ #endif
++#ifdef HAVE_ITDB_MEDIATYPE
++ track->mediatype = 0x02; // for videos
++#else
+ track->unk208 = 0x02; // for videos
++#endif
+ }
+ else if(type=="aa")
+ {
+@@ -341,7 +353,11 @@
+ #else
+ track->flag3 |= 0x01; // remember current position in track
+ #endif
++#ifdef HAVE_ITDB_MEDIATYPE
++ track->mediatype = 0x08; // for audiobooks
++#else
+ track->unk208 = 0x08; // for audiobooks
++#endif
+
+ TagLib::Audible::File f( QFile::encodeName( propertiesBundle.url().path() ) );
+ TagLib::Audible::Tag *t = f.getAudibleTag();
+@@ -384,7 +400,11 @@
+ #ifdef HAVE_ITDB_MARK_UNPLAYED
+ track->mark_unplayed = podcastInfo->listened ? 0x01 : 0x02;
+ #endif
++#ifdef HAVE_ITDB_MEDIATYPE
++ track->mediatype = track->mediatype==0x02 ? 0x06 : 0x04; // video or audio podcast
++#else
+ track->unk208 = track->unk208==0x02 ? 0x06 : 0x04; // video or audio podcast
++#endif
+ track->flag4 = 0x01; // also show description on iPod
+ QString plaindesc = podcastInfo->description;
+ plaindesc.replace( QRegExp("<[^>]*>"), "" );
+Index: configure.in.in
+===================================================================
+--- amarok-svn/amarok/configure.in.in (revision 605590)
++++ amarok-svn/amarok/configure.in.in (revision 605591)
+@@ -910,6 +910,11 @@
+ ,
+ [#include <gpod/itdb.h>])
+
++ AC_CHECK_MEMBER(struct _Itdb_Track.mediatype,
++ [AC_DEFINE(HAVE_ITDB_MEDIATYPE, 1, [have libgpod mediatype flag])],
++ ,
++ [#include <gpod/itdb.h>])
++
+ CPPFLAGS=$ac_cppflags_save
+ CFLAGS=$ac_cflags_save
+ LDFLAGS=$ac_ldflags_save