summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-10 03:35:26 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-10 03:35:26 +0000
commitf8088428c647828d026bcf6bf2c5d254989c8fc3 (patch)
tree2efd791f6f520ebc4575d42439dcd209d1b5559d /media-sound/amarok
parentBumped to version 2.9.4. (diff)
downloadgentoo-2-f8088428c647828d026bcf6bf2c5d254989c8fc3.tar.gz
gentoo-2-f8088428c647828d026bcf6bf2c5d254989c8fc3.tar.bz2
gentoo-2-f8088428c647828d026bcf6bf2c5d254989c8fc3.zip
Bumped amarok to version 1.90. Version 1.92 will remain masked in the ovelay due to the dep in mysql[embedded].
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-1.90.ebuild69
-rw-r--r--media-sound/amarok/metadata.xml24
3 files changed, 90 insertions, 12 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index b45326f9bfcc..4a2e458c0ccc 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.284 2008/10/04 08:49:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.285 2008/10/10 03:35:26 jmbsvicetto Exp $
+
+*amarok-1.90 (10 Oct 2008)
+
+ 10 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-1.90.ebuild:
+ Bumped amarok to version 1.90. Version 1.92 will remain masked in the
+ ovelay due to the dep in mysql[embedded].
04 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> metadata.xml:
Remove duplicate flags from metadata. Some were alreay well explained in
diff --git a/media-sound/amarok/amarok-1.90.ebuild b/media-sound/amarok/amarok-1.90.ebuild
new file mode 100644
index 000000000000..b21e49d763a8
--- /dev/null
+++ b/media-sound/amarok/amarok-1.90.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.90.ebuild,v 1.1 2008/10/10 03:35:26 jmbsvicetto Exp $
+
+EAPI="2"
+
+NEED_KDE=":4.1"
+inherit kde4-base
+
+# Install to KDEDIR rather than /usr, to slot properly.
+PREFIX="${KDEDIR}"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4.1"
+IUSE="cdaudio daap debug ifp ipod mp3tunes mp4 mtp mysql njb opengl visualization"
+SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+
+# daap are automagic
+
+DEPEND="
+ >=app-misc/strigi-0.5.7
+ dev-db/sqlite:3
+ kde-base/kdelibs:${SLOT}
+ kde-base/libplasma:${SLOT}
+ >=media-libs/taglib-1.5
+ || ( media-sound/phonon x11-libs/qt-phonon:4 )
+ x11-libs/qt-webkit:4
+ cdaudio? ( kde-base/libkcddb:${SLOT}
+ kde-base/libkcompactdisc:${SLOT} )
+ ifp? ( media-libs/libifp )
+ ipod? ( >=media-libs/libgpod-0.4.2 )
+ mp3tunes? ( net-misc/curl
+ dev-libs/libxml2 )
+ mp4? ( media-libs/libmp4v2 )
+ mtp? ( >=media-libs/libmtp-0.1.1 )
+ mysql? ( >=virtual/mysql-4.0 )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ opengl? ( virtual/opengl )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ "
+RDEPEND="${DEPEND}
+ app-arch/unzip
+ daap? ( www-servers/mongrel )
+ "
+
+src_configure() {
+ if use debug; then
+ mycmakeargs="${mycmakeargs} -DCMAKE_BUILD_TYPE=debugfull"
+ fi
+ mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+ -DUSE_SYSTEM_SQLITE=ON
+ $(cmake-utils_use_with cdaudio KdeMultimedia)
+ $(cmake-utils_use_with ifp Ifp)
+ $(cmake-utils_use_with ipod Ipod)
+ $(cmake-utils_use_with mp4 Mp4v2)
+ $(cmake-utils_use_with mtp Mtp)
+ $(cmake-utils_use_with mysql MySQL)
+ $(cmake-utils_use_with njb Njb)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with visualization Libvisual)
+ "
+ kde4-base_src_configure
+}
diff --git a/media-sound/amarok/metadata.xml b/media-sound/amarok/metadata.xml
index d98f7c842e67..bed83f0ec0f7 100644
--- a/media-sound/amarok/metadata.xml
+++ b/media-sound/amarok/metadata.xml
@@ -8,13 +8,8 @@
<name>Thomas Anderson</name>
</maintainer>
<use>
- <flag name="mp4">
- Build the TagLib plugin for writing tags in Mp4 container files
- (m4a). Please note that by enabling this USE flag, the resulting
- package will not be redistributable, as it links to
- <pkg>media-libs/libmp4v2</pkg>, distributed under a
- GPL-incompatible license.
- </flag>
+ <flag name="amazon">Enable support for downloading covers from amazon.com</flag>
+ <flag name="cdaudio">Enable cdaudio functionality</flag>
<flag name="daap">
Enable the scripts for music sharing through DAAP. This flag
adds dependencies on <pkg>www-servers/mongrel</pkg> to allow
@@ -22,6 +17,17 @@
protocol. Please note that turning this flag off has no effect
on DAAP browsing.
</flag>
+ <flag name="ifp">Enable support for iRiver devices access through libifp</flag>
+ <flag name="mp3tunes">Enable mp3tunes integration</flag>
+ <flag name="mp4">
+ Build the TagLib plugin for writing tags in Mp4 container files
+ (m4a). Please note that by enabling this USE flag, the resulting
+ package will not be redistributable, as it links to
+ <pkg>media-libs/libmp4v2</pkg>, distributed under a
+ GPL-incompatible license.
+ </flag>
+ <flag name="mtp">Enable support for libMTP (Plays4Sure) devices access through libmtp</flag>
+ <flag name="njb">Enable support for NJB (Creative) devices access through libnjb</flag>
<flag name="python">
Install the Amarok scripts written in Python, depending on
<pkg>dev-python/PyQt</pkg>. At the moment the only script
@@ -36,10 +42,6 @@
package will not be redistributable, as it links to the non-GPL compatible
RealPlayer.
</flag>
- <flag name="amazon">Enable support for downloading covers from amazon.com</flag>
- <flag name="ifp">Enable support for iRiver devices access through libifp</flag>
- <flag name="mtp">Enable support for libMTP (Plays4Sure) devices access through libmtp</flag>
- <flag name="njb">Enable support for NJB (Creative) devices access through libnjb</flag>
<flag name="visualization">Support visualization plugins through <pkg>media-libs/libvisual</pkg></flag>
</use>
</pkgmetadata>