summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2006-02-21 19:29:57 +0000
committerEldad Zack <eldad@gentoo.org>2006-02-21 19:29:57 +0000
commiteaf439f78a3329a543a2343a9c001bd13e3dd730 (patch)
tree97bea60d59818d0bbc7a1e85b44ce570850353a2 /media-sound/ardour
parentMinor fixes and openal is back (diff)
downloadgentoo-2-eaf439f78a3329a543a2343a9c001bd13e3dd730.tar.gz
gentoo-2-eaf439f78a3329a543a2343a9c001bd13e3dd730.tar.bz2
gentoo-2-eaf439f78a3329a543a2343a9c001bd13e3dd730.zip
version bump
(Portage version: 2.0.54)
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/ChangeLog7
-rw-r--r--media-sound/ardour/Manifest14
-rw-r--r--media-sound/ardour/ardour-0.99.2.ebuild91
-rw-r--r--media-sound/ardour/files/digest-ardour-0.99.21
4 files changed, 101 insertions, 12 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index b9a477f2074f..8c2e4808e529 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ardour
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.51 2006/02/08 16:36:14 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.52 2006/02/21 19:29:57 eldad Exp $
+
+*ardour-0.99.2 (21 Feb 2006)
+
+ 21 Feb 2006; Eldad Zack <eldad@gentoo.org> +ardour-0.99.2.ebuild:
+ Version bump
*ardour-0.99.1 (08 Feb 2006)
diff --git a/media-sound/ardour/Manifest b/media-sound/ardour/Manifest
index e2586d2c5df3..da5e48179d33 100644
--- a/media-sound/ardour/Manifest
+++ b/media-sound/ardour/Manifest
@@ -1,20 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 7b75ec4ab0a4da34cc92909f15733c91 ChangeLog 8111
+MD5 78ae9a798566526654d0bb74b4296a0c ChangeLog 8225
MD5 384882d9cc791783245700ba20ffe40f ardour-0.99.1.ebuild 2286
+MD5 893228c6e27459f2a3409e9485f32ede ardour-0.99.2.ebuild 2286
MD5 157cb460576b0ee78d1bb0418d183624 ardour-0.99.ebuild 2241
MD5 d2b8fe2b0b5029f2b87ccd646c46159d ardour-0.9_beta30.ebuild 2110
MD5 e016dfbfc8e85547954395c455b04e61 files/ardour-gcc34.patch 9562
MD5 11e862600d9c027d453d23dc2bf8763d files/ardour.aclocal.patch 8594
MD5 323d42579941b3e8210af7e9c21e8442 files/digest-ardour-0.99 65
MD5 a8efcf187759f3645b866ddc08614477 files/digest-ardour-0.99.1 67
+MD5 b455584ef334c3b4df67f18f2863b139 files/digest-ardour-0.99.2 67
MD5 674b91595af44849fde8356f9b4fba70 files/digest-ardour-0.9_beta30 70
MD5 28188f1657f0547a15f682ed3626a397 metadata.xml 330
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFD6h4WT+MN7JbqCpMRAmUKAJ4gNZZSN8VFPZikzcMqimhAGco00gCeM9nq
-Rsjw9cKg7jVeGO+ZIyV+l6Q=
-=y+ld
------END PGP SIGNATURE-----
diff --git a/media-sound/ardour/ardour-0.99.2.ebuild b/media-sound/ardour/ardour-0.99.2.ebuild
new file mode 100644
index 000000000000..b8fdbf3ac525
--- /dev/null
+++ b/media-sound/ardour/ardour-0.99.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-0.99.2.ebuild,v 1.1 2006/02/21 19:29:57 eldad Exp $
+
+inherit eutils
+
+DESCRIPTION="multi-track hard disk recording software"
+HOMEPAGE="http://ardour.org/"
+SRC_URI="http://ardour.org/releases/${P/_/}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="nls debug sse altivec"
+
+# From beta30 release notes:
+# plugin latency compensation now working correctly (we believe)
+# This really requires JACK 0.100.0 or above to work
+# properly, but even without that, they result in notable improvements
+# in the way Ardour aligns newly recorded material.
+#
+# As media-sound/jack-audio-connection-kit-0.100.0 is still -arch and it is not required for beta30
+# only suggested, RDEPEND needs to be updated as media-sound/jack-audio-connection-kit-0.100.0 gets
+# into ~arch. (2005 Sep 14 eldad)
+
+RDEPEND="dev-util/pkgconfig
+ >=media-libs/liblrdf-0.3.6
+ >=media-libs/raptor-1.2.0
+ >=media-sound/jack-audio-connection-kit-0.98.1
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=media-libs/libsndfile-1.0.4
+ sys-libs/gdbm
+ >=media-libs/ladspa-sdk-1.12
+ >=media-libs/libsamplerate-0.0.14
+ >=dev-libs/libxml2-2.5.7
+ >=media-libs/libart_lgpl-2.3.16"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ dev-util/pkgconfig
+ >=dev-util/scons-0.96.1
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${P/_/}"
+
+src_compile() {
+ # bug 99664
+ cd ${S}/libs/gtkmm
+ chmod a+x autogen.sh && ./autogen.sh || die "autogen failed"
+ econf || die "configure failed"
+
+ # Required for scons to "see" intermediate install location
+ mkdir -p ${D}
+
+ use altivec && ALTIVEC=1 || ALTIVEC=0
+ use debug && ARDOUR_DEBUG=1 || ARDOUR_DEBUG=0
+ use nls && NLS=1 || NLS=0
+ use sse && SSE=1 || SSE=0
+
+ cd ${S}
+ scons \
+ ALTIVEC=${ALTIVEC} \
+ DEBUG=${ARDOUR_DEBUG} \
+ DESTDIR=${D} \
+ NLS=${NLS} \
+ PREFIX=/usr \
+ USE_SSE_EVERYWHERE=${SSE} \
+ KSI=0 \
+ -j2
+}
+
+src_install() {
+ scons install || die "make install failed"
+
+ dodoc DOCUMENTATION/*
+}
+
+pkg_postinst() {
+ if useq sse
+ then
+ einfo ""
+ einfo "Start ardour with the -o argument to use the optimized SSE functions:"
+ einfo ""
+ einfo " ardour -o"
+ einfo ""
+ fi
+}
+
diff --git a/media-sound/ardour/files/digest-ardour-0.99.2 b/media-sound/ardour/files/digest-ardour-0.99.2
new file mode 100644
index 000000000000..13101fd6262a
--- /dev/null
+++ b/media-sound/ardour/files/digest-ardour-0.99.2
@@ -0,0 +1 @@
+MD5 d1f00f9fb1c430ce3f8b6bfa2f270594 ardour-0.99.2.tar.bz2 1314260