summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-11-21 15:33:00 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-11-21 15:33:00 +0000
commit3becc5b4af34d743ab914559b8672f900852da9b (patch)
treeb77abcf94a0496d0b53006d350d985ebdbc1eeab /media-sound/audacious
parentStable for HPPA (bug #198536). (diff)
downloadgentoo-2-3becc5b4af34d743ab914559b8672f900852da9b.tar.gz
gentoo-2-3becc5b4af34d743ab914559b8672f900852da9b.tar.bz2
gentoo-2-3becc5b4af34d743ab914559b8672f900852da9b.zip
Version bump. Make D-Bus optional and warn when off, closes bug #199069. More resilient skin loading and doublesize code from upstream resolves bug #199071.
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog9
-rw-r--r--media-sound/audacious/audacious-1.4.2.ebuild66
-rw-r--r--media-sound/audacious/files/digest-audacious-1.4.26
3 files changed, 80 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 876bba2b1c0d..bd0eb65a14a8 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.129 2007/11/10 16:53:13 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.130 2007/11/21 15:32:59 chainsaw Exp $
+
+*audacious-1.4.2 (21 Nov 2007)
+
+ 21 Nov 2007; Tony Vroon <chainsaw@gentoo.org> +audacious-1.4.2.ebuild:
+ Version bump. Make D-Bus optional and warn when off, closes bug #199069.
+ More resilient skin loading and doublesize code from upstream resolves bug
+ #199071.
10 Nov 2007; Tony Vroon <chainsaw@gentoo.org> -audacious-1.1.2.ebuild,
-audacious-1.1.2-r1.ebuild, -audacious-1.2.2.ebuild,
diff --git a/media-sound/audacious/audacious-1.4.2.ebuild b/media-sound/audacious/audacious-1.4.2.ebuild
new file mode 100644
index 000000000000..84e9c77223f5
--- /dev/null
+++ b/media-sound/audacious/audacious-1.4.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.4.2.ebuild,v 1.1 2007/11/21 15:32:59 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="chardet dbus nls libsamplerate"
+
+RDEPEND="dbus? ( >=dev-libs/dbus-glib-0.60 )
+ libsamplerate? ( media-libs/libsamplerate )
+ >=dev-libs/libmcs-0.6.0
+ >=dev-libs/libmowgli-0.5.0
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.10"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.4.1"
+
+src_compile() {
+ econf \
+ $(use_enable chardet) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins for Audacious 1.4"
+ elog "Plugins compiled against 1.3 will not be loaded."
+ if ! useq dbus ; then
+ ewarn "D-Bus has been disabled. Note that audtool will not be provided, you will not"
+ ewarn "be to able to get song information from scripts or control the player remotely."
+ else
+ elog "Remote control is now only provided over D-Bus. Audacious offers both a private "
+ elog "interface and an MPRIS compliant interface on the bus."
+ fi
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.4.2 b/media-sound/audacious/files/digest-audacious-1.4.2
new file mode 100644
index 000000000000..be7666e53f09
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.4.2
@@ -0,0 +1,6 @@
+MD5 556fd4adb713540c0a0e6dbb06d910c6 audacious-1.4.2.tgz 1824239
+RMD160 c83e81d309b6ef2412ca730bcb5c42c4f858f743 audacious-1.4.2.tgz 1824239
+SHA256 6726dde51887a9d6a39c26e561c4faee50246300f209f6c363efacc973284136 audacious-1.4.2.tgz 1824239
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839