summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-12-31 11:44:50 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-12-31 11:44:50 +0000
commit50ddf72609340ec919010d0643116993b47a1662 (patch)
tree8544bfbfb060514ea4123e15d8be6c205479cb85 /media-sound/audacious
parentVersion bump (bug #203806). Dropped old versions. (diff)
downloadgentoo-2-50ddf72609340ec919010d0643116993b47a1662.tar.gz
gentoo-2-50ddf72609340ec919010d0643116993b47a1662.tar.bz2
gentoo-2-50ddf72609340ec919010d0643116993b47a1662.zip
Version bump. Numerous bugfixes.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-1.4.5.ebuild72
-rw-r--r--media-sound/audacious/files/digest-audacious-1.4.56
3 files changed, 84 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 1586b30d1bcf..2887774f8067 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.133 2007/12/03 18:00:35 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.134 2007/12/31 11:44:50 chainsaw Exp $
+
+*audacious-1.4.5 (31 Dec 2007)
+
+ 31 Dec 2007; Tony Vroon <chainsaw@gentoo.org> +audacious-1.4.5.ebuild:
+ Version bump. Numerous bugfixes.
*audacious-1.4.4 (03 Dec 2007)
diff --git a/media-sound/audacious/audacious-1.4.5.ebuild b/media-sound/audacious/audacious-1.4.5.ebuild
new file mode 100644
index 000000000000..0e9d0e0c9392
--- /dev/null
+++ b/media-sound/audacious/audacious-1.4.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.4.5.ebuild,v 1.1 2007/12/31 11:44:50 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="chardet dbus nls libsamplerate"
+
+RDEPEND="dbus? ( >=dev-libs/dbus-glib-0.60 )
+ libsamplerate? ( media-libs/libsamplerate )
+ >=dev-libs/libmcs-0.6.0
+ >=dev-libs/libmowgli-0.5.0
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.10"
+
+DEPEND="${RDEPEND}
+ !media-plugins/audacious-plugins-ugly
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.4.3.2"
+
+src_compile() {
+ econf \
+ $(use_enable chardet) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins for Audacious 1.4"
+ elog "Plugins compiled against 1.3 will not be loaded."
+ if ! useq dbus ; then
+ eerror "Unsupported configuration: D-Bus disabled"
+ ewarn "D-Bus has been disabled. Note that audtool will not be provided, you will not"
+ ewarn "be to able to get song information from scripts or control the player remotely."
+ ewarn "This configuration is provided for people heavily opposed to D-Bus that are able "
+ ewarn "to live with the loss of functionality that this implies. Reports about remote "
+ ewarn "control or multiple instances of Audacious being launched will be *closed*."
+ else
+ elog "Remote control is now only provided over D-Bus. Audacious offers both a private "
+ elog "interface and an MPRIS compliant interface on the bus. The older interface using "
+ elog "beepctrl.h is no longer present."
+ fi
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.4.5 b/media-sound/audacious/files/digest-audacious-1.4.5
new file mode 100644
index 000000000000..fbd24345aa1a
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.4.5
@@ -0,0 +1,6 @@
+MD5 db898864e14770c6ad063aa83bf11aa7 audacious-1.4.5.tgz 1838889
+RMD160 65f0a365237c588c2e1d08d326fc3a08cfa7a677 audacious-1.4.5.tgz 1838889
+SHA256 890bf3ca24b6e4af9983b95a72ce56db8cd0ada3b54184ae9c9258e9b6d9ff90 audacious-1.4.5.tgz 1838889
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839