summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-04-19 02:13:50 +0000
committerTim Harder <radhermit@gentoo.org>2011-04-19 02:13:50 +0000
commit23922fb74cbdd727f11edc1e3a5d7c34aac17b44 (patch)
treea0e2f77735ef9ca5f7ecb342ab953dc972b6bcda /media-sound/audacity
parentFixed MAN paths (diff)
downloadgentoo-2-23922fb74cbdd727f11edc1e3a5d7c34aac17b44.tar.gz
gentoo-2-23922fb74cbdd727f11edc1e3a5d7c34aac17b44.tar.bz2
gentoo-2-23922fb74cbdd727f11edc1e3a5d7c34aac17b44.zip
Version bump (bug #363751). Migrate to virtual/ffmpeg (bug #362109) and update to EAPI 4.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog9
-rw-r--r--media-sound/audacity/audacity-1.3.13.ebuild93
-rw-r--r--media-sound/audacity/files/audacity-1.3.13-automagic.patch61
3 files changed, 162 insertions, 1 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 880758c6b085..b9f23b2729aa 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audacity
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.151 2011/03/24 15:59:17 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.152 2011/04/19 02:13:49 radhermit Exp $
+
+*audacity-1.3.13 (19 Apr 2011)
+
+ 19 Apr 2011; Tim Harder <radhermit@gentoo.org> +audacity-1.3.13.ebuild,
+ +files/audacity-1.3.13-automagic.patch:
+ Version bump (bug #363751). Migrate to virtual/ffmpeg (bug #362109) and
+ update to EAPI 4.
24 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
audacity-1.3.12.ebuild:
diff --git a/media-sound/audacity/audacity-1.3.13.ebuild b/media-sound/audacity/audacity-1.3.13.ebuild
new file mode 100644
index 000000000000..e0244d0a7265
--- /dev/null
+++ b/media-sound/audacity/audacity-1.3.13.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.13.ebuild,v 1.1 2011/04/19 02:13:50 radhermit Exp $
+
+EAPI=4
+
+inherit eutils wxwidgets autotools versionator
+
+MY_PV=$(replace_version_separator 3 -)
+MY_P="${PN}-src-${MY_PV}-beta"
+MY_T="${PN}-minsrc-${MY_PV}-beta"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_T}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa ffmpeg flac id3tag jack ladspa libsamplerate midi mp3 soundtouch twolame vamp vorbis"
+RESTRICT="test"
+
+COMMON_DEPEND="x11-libs/wxGTK:2.8[X]
+ >=app-arch/zip-2.3
+ >=media-libs/libsndfile-1.0.0
+ dev-libs/expat
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+ mp3? ( >=media-libs/libmad-0.14.2b )
+ flac? ( >=media-libs/flac-1.2.0[cxx] )
+ id3tag? ( media-libs/libid3tag )
+ soundtouch? ( >=media-libs/libsoundtouch-1.3.1 )
+ vamp? ( >=media-libs/vamp-plugin-sdk-2.0 )
+ twolame? ( media-sound/twolame )
+ ffmpeg? ( virtual/ffmpeg )
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.103.0 )"
+# Crashes at startup here...
+# lv2? ( >=media-libs/slv2-0.6.0 )
+# Disabled upstream ATM
+# ladspa? ( >=media-libs/liblrdf-0.4.0 )
+
+RDEPEND="${COMMON_DEPEND}
+ mp3? ( >=media-sound/lame-3.70 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-automagic.patch"
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_configure() {
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+
+ # * always use system libraries if possible
+ # * options listed in the order that configure --help lists them
+ # * if libsamplerate not requested, use libresample instead.
+ econf \
+ --enable-unicode \
+ --enable-nyquist \
+ $(use_enable ladspa) \
+ --with-libsndfile=system \
+ --with-expat=system \
+ $(use_with libsamplerate) \
+ $(use_with !libsamplerate libresample) \
+ $(use_with vorbis libvorbis) \
+ $(use_with mp3 libmad) \
+ $(use_with flac libflac) \
+ $(use_with id3tag libid3tag) \
+ $(use_with soundtouch) \
+ $(use_with vamp libvamp) \
+ $(use_with twolame libtwolame) \
+ $(use_with ffmpeg) \
+ $(use_with midi) \
+ $(use_with alsa) \
+ $(use_with jack)
+}
+
+# $(use_with lv2 slv2) \
+# $(use_with ladspa liblrdf) \
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove bad doc install
+ rm -rf "${D}"/usr/share/doc
+
+ # Install our docs
+ dodoc README.txt
+}
diff --git a/media-sound/audacity/files/audacity-1.3.13-automagic.patch b/media-sound/audacity/files/audacity-1.3.13-automagic.patch
new file mode 100644
index 000000000000..4e7c2917e5db
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.13-automagic.patch
@@ -0,0 +1,61 @@
+--- audacity-src-1.3.13-beta.orig/configure.in
++++ audacity-src-1.3.13-beta/configure.in
+@@ -173,6 +173,9 @@
+ lib_preference=$withval,
+ lib_preference="system local")
+
++AC_ARG_WITH([alsa], AS_HELP_STRING([--without-alsa], [Build without alsa library (default: test)]))
++AC_ARG_WITH([jack], AS_HELP_STRING([--without-jack], [Build without jack library (default: test)]))
++
+ dnl AC_ARG_WITH(wx-version,
+ dnl [AS_HELP_STRING([--with-wx-version],
+ dnl [select wxWidgets version (if both installed) [2.8,]])],
+@@ -574,13 +577,21 @@
+ ;;
+ *)
+ dnl Unix
+- AC_CHECK_LIB(asound, snd_pcm_open, have_alsa=yes, have_alsa=no)
+- if [[ $have_alsa = "yes" ]] ; then
+- LIBS="$LIBS -lasound"
+- fi
+- PKG_CHECK_MODULES(JACK, jack, have_jack=yes, have_jack=no)
+- if [[ $have_jack = "yes" ]] ; then
+- LIBS="$LIBS $JACK_LIBS"
++ if test "x$with_alsa" != "xno"; then
++ AC_CHECK_LIB(asound, snd_pcm_open, have_alsa=yes, have_alsa=no)
++ if [[ $have_alsa = "yes" ]] ; then
++ LIBS="$LIBS -lasound"
++ else
++ AC_MSG_WARN([Support for alsa not available])
++ fi
++ fi
++ if test "x$with_jack" != "xno"; then
++ PKG_CHECK_MODULES(JACK, jack, have_jack=yes, have_jack=no)
++ if [[ $have_jack = "yes" ]] ; then
++ LIBS="$LIBS $JACK_LIBS"
++ else
++ AC_MSG_WARN([Support for jack not available])
++ fi
+ fi
+ AC_CHECK_LIB(hpi, HPI_SubSysCreate, have_asihpi=yes, have_asihpi=no, -lm)
+ if [[ $have_asihpi = "yes" ]] ; then
+--- audacity-src-1.3.13-beta.orig/lib-src/portmixer/configure.ac
++++ audacity-src-1.3.13-beta/lib-src/portmixer/configure.ac
+@@ -31,6 +31,8 @@
+ [AC_SUBST( cflags, ["$cflags -g"] ) AC_MSG_RESULT(yes)],
+ [AC_SUBST( cflags, ["$cflags -O2"] ) AC_MSG_RESULT(no)])
+
++AC_ARG_WITH([alsa], AC_HELP_STRING([--without-alsa], [Build without alsa library (default: test)]))
++
+ #
+ # Check for portaudio path
+ #
+@@ -133,7 +135,7 @@
+ have_support=yes
+ fi
+
+-if [[ $have_alsa = "yes" ]] ; then
++if [[ $have_alsa = "yes" -a "x$with_alsa" != "xno" ]] ; then
+ AC_MSG_NOTICE([Including support for ALSA])
+ AC_DEFINE(PX_USE_LINUX_ALSA)
+ objects="$objects px_linux_alsa.o"