summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 11:00:39 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 11:00:39 +0000
commit0176f0e869bebff5a246fbbabf7585246834d1aa (patch)
tree4ec0015d0b4caa74b800ebdac3492f4ff6d230e7 /media-sound/aumix
parent*** empty log message *** (diff)
downloadgentoo-2-0176f0e869bebff5a246fbbabf7585246834d1aa.tar.gz
gentoo-2-0176f0e869bebff5a246fbbabf7585246834d1aa.tar.bz2
gentoo-2-0176f0e869bebff5a246fbbabf7585246834d1aa.zip
A console mixer
Diffstat (limited to 'media-sound/aumix')
-rw-r--r--media-sound/aumix/aumix-2.7.ebuild40
-rw-r--r--media-sound/aumix/files/digest-aumix-2.71
2 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/aumix/aumix-2.7.ebuild b/media-sound/aumix/aumix-2.7.ebuild
new file mode 100644
index 000000000000..dd0437dccc26
--- /dev/null
+++ b/media-sound/aumix/aumix-2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Aaron Blew <moath@oddbox.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Aumix volume/mixer control program."
+SRC_URI="http://jpj.net/~trevor/aumix/${A}"
+HOMEPAGE="http://jpj.net/~trevor/aumix/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/gpm-1.19.3
+ alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ gtk? ( >=x11-libs/gtk+-1.2.10 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ -z "`use gtk`" ] ; then
+ myconf="$myconf --without-gtk"
+ fi
+ if [ -z "`use alsa`" ] ; then
+ myconf="$myconf --without-alsa"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README TODO
+}
+
diff --git a/media-sound/aumix/files/digest-aumix-2.7 b/media-sound/aumix/files/digest-aumix-2.7
new file mode 100644
index 000000000000..ecbe0034830c
--- /dev/null
+++ b/media-sound/aumix/files/digest-aumix-2.7
@@ -0,0 +1 @@
+MD5 84ecc331bf6d86d3ac925590fee83af7 aumix-2.7.tar.gz