summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-10-18 22:37:56 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-10-18 22:37:56 +0000
commitd62be60cf28a4e8ce92238414a1cc2b5e56f760f (patch)
tree088109ec9d2b3d231efe3c2b713dd33079ad7573 /media-sound/brutefir/brutefir-1.0f.ebuild
parentInitial commit. Closes bug #109195 (diff)
downloadgentoo-2-d62be60cf28a4e8ce92238414a1cc2b5e56f760f.tar.gz
gentoo-2-d62be60cf28a4e8ce92238414a1cc2b5e56f760f.tar.bz2
gentoo-2-d62be60cf28a4e8ce92238414a1cc2b5e56f760f.zip
Version bump, closes bug #108906.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'media-sound/brutefir/brutefir-1.0f.ebuild')
-rw-r--r--media-sound/brutefir/brutefir-1.0f.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/brutefir/brutefir-1.0f.ebuild b/media-sound/brutefir/brutefir-1.0f.ebuild
new file mode 100644
index 000000000000..277afa389037
--- /dev/null
+++ b/media-sound/brutefir/brutefir-1.0f.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/brutefir/brutefir-1.0f.ebuild,v 1.1 2005/10/18 22:37:56 chainsaw Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="BruteFIR is a software convolution engine, a program for applying long FIR filters to multi-channel digital audio, either offline or in realtime."
+HOMEPAGE="http://www.ludd.luth.se/~torger/brutefir.html"
+SRC_URI="http://www.ludd.luth.se/~torger/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=media-libs/alsa-lib-0.9.1
+ media-sound/jack-audio-connection-kit
+ >=sci-libs/fftw-3.0.0"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/lib/brutefir
+
+ einstall DESTDIR=${D} \
+ INSTALL_PREFIX=${D}/usr || die "make install failed"
+
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
+
+ dodoc CHANGES README LICENSE
+
+ insinto usr/share/brutefir
+ doins xtc_config directpath.txt crosspath.txt massive_config bench1_config bench2_config bench3_config bench4_config bench5_config
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Brutefir is a complicated piece of software. Please"
+ einfo "read the documentation first! You can find"
+ einfo "documentation here: http://www.ludd.luth.se/~torger/brutefir.html"
+ einfo "Example config files are in /usr/share/brutefir"
+ einfo
+}