summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 14:03:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 14:03:52 +0000
commit8b4f2cd40f4c8a8a5c192f9c2efb42367553bb7d (patch)
tree6be08e531b93eaf7e5045f94254dc727ddc67e5c /media-sound/cmix
parentRespect CC and LDFLAGS, add debug useflag. (diff)
downloadgentoo-2-8b4f2cd40f4c8a8a5c192f9c2efb42367553bb7d.tar.gz
gentoo-2-8b4f2cd40f4c8a8a5c192f9c2efb42367553bb7d.tar.bz2
gentoo-2-8b4f2cd40f4c8a8a5c192f9c2efb42367553bb7d.zip
Drop virtual/libc dependency. Respect CC and LDFLAGS, don't strip binaries unconditionally.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'media-sound/cmix')
-rw-r--r--media-sound/cmix/ChangeLog9
-rw-r--r--media-sound/cmix/cmix-1.6.ebuild17
-rw-r--r--media-sound/cmix/files/cmix-1.6-ldflags.patch14
3 files changed, 33 insertions, 7 deletions
diff --git a/media-sound/cmix/ChangeLog b/media-sound/cmix/ChangeLog
index 8c08209a7864..7ebad2f8c625 100644
--- a/media-sound/cmix/ChangeLog
+++ b/media-sound/cmix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/cmix
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cmix/ChangeLog,v 1.9 2005/09/04 10:35:00 flameeyes Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cmix/ChangeLog,v 1.10 2006/03/07 14:03:52 flameeyes Exp $
+
+ 07 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/cmix-1.6-ldflags.patch, cmix-1.6.ebuild:
+ Drop virtual/libc dependency. Respect CC and LDFLAGS, don't strip binaries
+ unconditionally.
04 Sep 2005; Diego Pettenò <flameeyes@gentoo.org> cmix-1.6.ebuild:
Don't install COPYING file.
diff --git a/media-sound/cmix/cmix-1.6.ebuild b/media-sound/cmix/cmix-1.6.ebuild
index 5a1db03039a8..a46c8fb215bc 100644
--- a/media-sound/cmix/cmix-1.6.ebuild
+++ b/media-sound/cmix/cmix-1.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cmix/cmix-1.6.ebuild,v 1.13 2005/09/04 10:35:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cmix/cmix-1.6.ebuild,v 1.14 2006/03/07 14:03:52 flameeyes Exp $
+
+inherit eutils toolchain-funcs
IUSE=""
@@ -10,13 +12,18 @@ SRC_URI="http://antipoder.dyndns.org/downloads/${P}.tbz2"
LICENSE="GPL-2"
SLOT="0"
-#-amd64: 1.6: 'cmix list' gives: MIXER_READ(SOUND_MIXER_OUTSRC): Input/output error
+#-amd64: 1.6: 'cmix list' gives: MIXER_READ(SOUND_MIXER_OUTSRC): Input/output error
KEYWORDS="-amd64 ~ppc sparc x86"
-DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
src_compile() {
- make || die
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {
diff --git a/media-sound/cmix/files/cmix-1.6-ldflags.patch b/media-sound/cmix/files/cmix-1.6-ldflags.patch
new file mode 100644
index 000000000000..ba8dacb2567b
--- /dev/null
+++ b/media-sound/cmix/files/cmix-1.6-ldflags.patch
@@ -0,0 +1,14 @@
+Index: cmix-1.6/Makefile
+===================================================================
+--- cmix-1.6.orig/Makefile
++++ cmix-1.6/Makefile
+@@ -3,8 +3,7 @@ CC=gcc
+ #CFLAGS=-Wall -O2
+
+ cmix: mix.c
+- $(CC) $(CFLAGS) mix.c -o $@
+- strip $@
++ $(CC) $(CFLAGS) $(LDFLAGS) mix.c -o $@
+
+ install:
+