summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-04-22 16:09:22 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-04-22 16:09:22 +0000
commit16caea137200a6feb931eb8792d1e32322634ca6 (patch)
tree5ef54640ba446658bf85e9094f983a245891ad93 /media-sound/codecgraph
parentStable on amd64; bug 208908 (diff)
downloadgentoo-2-16caea137200a6feb931eb8792d1e32322634ca6.tar.gz
gentoo-2-16caea137200a6feb931eb8792d1e32322634ca6.tar.bz2
gentoo-2-16caea137200a6feb931eb8792d1e32322634ca6.zip
Version bump. Install more documentation.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'media-sound/codecgraph')
-rw-r--r--media-sound/codecgraph/ChangeLog8
-rw-r--r--media-sound/codecgraph/codecgraph-20080422.ebuild34
-rw-r--r--media-sound/codecgraph/files/20080422-makefile-prefix.diff8
3 files changed, 49 insertions, 1 deletions
diff --git a/media-sound/codecgraph/ChangeLog b/media-sound/codecgraph/ChangeLog
index 3ccbb54243bf..fe26d7fa4d65 100644
--- a/media-sound/codecgraph/ChangeLog
+++ b/media-sound/codecgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/codecgraph
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/codecgraph/ChangeLog,v 1.1 2008/03/14 12:08:53 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/codecgraph/ChangeLog,v 1.2 2008/04/22 16:09:21 chainsaw Exp $
+
+*codecgraph-20080422 (22 Apr 2008)
+
+ 22 Apr 2008; <chainsaw@gentoo.org> +files/20080422-makefile-prefix.diff,
+ +codecgraph-20080422.ebuild:
+ Version bump. Install more documentation.
*codecgraph-20080311 (14 Mar 2008)
diff --git a/media-sound/codecgraph/codecgraph-20080422.ebuild b/media-sound/codecgraph/codecgraph-20080422.ebuild
new file mode 100644
index 000000000000..83c3b525c588
--- /dev/null
+++ b/media-sound/codecgraph/codecgraph-20080422.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/codecgraph/codecgraph-20080422.ebuild,v 1.1 2008/04/22 16:09:21 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="Generates a graph based on the ALSA description of an HD Audio codec."
+HOMEPAGE="http://helllabs.org/codecgraph/"
+SRC_URI="http://helllabs.org/codecgraph/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/python
+ media-gfx/graphviz"
+
+DEPEND="${RDEPEND}
+ media-gfx/imagemagick"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-makefile-prefix.diff"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc codecs.txt README BUGS IDEAS
+}
diff --git a/media-sound/codecgraph/files/20080422-makefile-prefix.diff b/media-sound/codecgraph/files/20080422-makefile-prefix.diff
new file mode 100644
index 000000000000..1132ccef5fe3
--- /dev/null
+++ b/media-sound/codecgraph/files/20080422-makefile-prefix.diff
@@ -0,0 +1,8 @@
+--- codecgraph-20080422/Makefile.orig 2008-04-22 16:50:14.000000000 +0100
++++ codecgraph-20080422/Makefile 2008-04-22 16:50:21.000000000 +0100
+@@ -1,4 +1,4 @@
+-PREFIX = /usr/local
++PREFIX = /usr
+ DOTTY = dot
+
+ samples = \