summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-09-09 08:22:35 +0000
committerRémi Cardona <remi@gentoo.org>2007-09-09 08:22:35 +0000
commit8b23f4c0902774d80adffd417c21e6a19697b1bc (patch)
tree8988402376b4645f5d49affad1a28002e97056b5 /media-sound/esound
parentfix squid-3 mask (diff)
downloadgentoo-2-8b23f4c0902774d80adffd417c21e6a19697b1bc.tar.gz
gentoo-2-8b23f4c0902774d80adffd417c21e6a19697b1bc.tar.bz2
gentoo-2-8b23f4c0902774d80adffd417c21e6a19697b1bc.zip
media-sound/esound: patch fixes messy html documentation installation (bugs #154902 and #191306)
(Portage version: 2.1.3.8)
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/ChangeLog8
-rw-r--r--media-sound/esound/esound-0.2.38-r1.ebuild76
-rw-r--r--media-sound/esound/files/digest-esound-0.2.38-r13
-rw-r--r--media-sound/esound/files/esound-0.2.38-doc.patch23
4 files changed, 109 insertions, 1 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index 6680f9975d1c..9d8acc95183a 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/esound
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.103 2007/08/28 17:47:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.104 2007/09/09 08:22:34 remi Exp $
+
+*esound-0.2.38-r1 (09 Sep 2007)
+
+ 09 Sep 2007; Rémi Cardona <remi@gentoo.org>
+ +files/esound-0.2.38-doc.patch, +esound-0.2.38-r1.ebuild:
+ patch fixes messy html documentation installation (bugs #154902 and #191306)
28 Aug 2007; Jeroen Roovers <jer@gentoo.org> esound-0.2.38.ebuild:
Stable for HPPA (bug #185823).
diff --git a/media-sound/esound/esound-0.2.38-r1.ebuild b/media-sound/esound/esound-0.2.38-r1.ebuild
new file mode 100644
index 000000000000..b91e9c1969c8
--- /dev/null
+++ b/media-sound/esound/esound-0.2.38-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.38-r1.ebuild,v 1.1 2007/09/09 08:22:34 remi Exp $
+
+WANT_AUTOMAKE=1.10
+inherit libtool gnome.org eutils autotools flag-o-matic
+
+DESCRIPTION="The Enlightened Sound Daemon"
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug doc ipv6 tcpd"
+
+# esound comes with arts support, but it hasn't been tested yet, feel free to
+# submit patches/improvements
+DEPEND=">=media-libs/audiofile-0.1.5
+ alsa? ( >=media-libs/alsa-lib-0.5.10b )
+ doc? ( app-text/docbook-sgml-utils )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+# arts? ( kde-base/arts )
+
+RDEPEND="${DEPEND}
+ app-admin/eselect-esd"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.2.32-amd64.patch"
+
+ epatch "${FILESDIR}/${PN}-0.2.36-mode_t.patch"
+ epatch "${FILESDIR}/${PN}-0.2.38-as-needed.patch"
+ epatch "${FILESDIR}/${PN}-0.2.38-doc.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ # Strict aliasing problem
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --sysconfdir=/etc/esd \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use_enable ipv6) \
+ $(use_enable debug debugging) \
+ $(use_enable alsa) \
+ $(use_with tcpd libwrap) \
+ --disable-dependency-tracking \
+ || die "Configure failed"
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Installation failed"
+ mv "${D}/usr/bin/"{esd,esound-esd}
+
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README TIPS TODO
+
+ newconfd "${FILESDIR}/esound.conf.d" esound
+
+ extradepend=""
+ use tcpd && extradepend=" portmap"
+ use alsa && extradepend="$extradepend alsasound"
+ sed -e "s/@extradepend@/$extradepend/" "${FILESDIR}/esound.init.d.2" >"${T}/esound"
+ doinitd "${T}/esound"
+}
+
+pkg_postinst() {
+ eselect esd update --if-unset \
+ || die "eselect failed, try removing /usr/bin/esd and re-emerging."
+}
diff --git a/media-sound/esound/files/digest-esound-0.2.38-r1 b/media-sound/esound/files/digest-esound-0.2.38-r1
new file mode 100644
index 000000000000..9e67ac80cc9d
--- /dev/null
+++ b/media-sound/esound/files/digest-esound-0.2.38-r1
@@ -0,0 +1,3 @@
+MD5 1c48c100b450d617b58dacb59837d34f esound-0.2.38.tar.bz2 393758
+RMD160 d12605bcd24b697a5525b0e266d2bbca43edea32 esound-0.2.38.tar.bz2 393758
+SHA256 08ea208cb3948650250bb068de5c75b877e78902d679e8af5d0a14062c939b37 esound-0.2.38.tar.bz2 393758
diff --git a/media-sound/esound/files/esound-0.2.38-doc.patch b/media-sound/esound/files/esound-0.2.38-doc.patch
new file mode 100644
index 000000000000..a873b90b664f
--- /dev/null
+++ b/media-sound/esound/files/esound-0.2.38-doc.patch
@@ -0,0 +1,23 @@
+--- configure.ac.old 2007-09-09 09:28:00.000000000 +0200
++++ configure.ac 2007-09-09 09:28:12.000000000 +0200
+@@ -25,9 +25,6 @@
+ AC_SUBST(ESD_VERSION)
+ AC_SUBST(ESD_VERSION_INFO)
+
+-pkgdocdir="\$(datadir)/doc/esound"
+-AC_SUBST(pkgdocdir)
+-
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_LIBTOOL_WIN32_DLL
+--- docs/Makefile.am.old 2007-09-09 09:37:28.000000000 +0200
++++ docs/Makefile.am 2007-09-09 09:38:59.000000000 +0200
+@@ -14,8 +14,6 @@
+
+ CLEANFILES = esound.dvi esound.ps esound.tex esound.aux esound.log
+
+-htmldir=$(pkgdocdir)/html
+-
+ if HAVE_JW
+ noinst_DATA = html/index.html
+ else