summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-07-27 19:53:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-07-27 19:53:59 +0000
commitbd6157de1cee58eda47f8e30d5e1952da25a92ef (patch)
treef3e28adb7f03908cc4a4aad4f2a168b1cbf79215 /media-sound/exaile
parentFix RDEPEND. (diff)
downloadgentoo-2-bd6157de1cee58eda47f8e30d5e1952da25a92ef.tar.gz
gentoo-2-bd6157de1cee58eda47f8e30d5e1952da25a92ef.tar.bz2
gentoo-2-bd6157de1cee58eda47f8e30d5e1952da25a92ef.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 981CA6FC)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog9
-rw-r--r--media-sound/exaile/exaile-3.4.5.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index dc6230bf86bb..bffaef1beb94 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/exaile
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.78 2011/10/20 02:52:13 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.79 2015/07/27 19:53:59 polynomial-c Exp $
+
+*exaile-3.4.5 (27 Jul 2015)
+
+ 27 Jul 2015; Lars Wendler <polynomial-c@gentoo.org> +exaile-3.4.5.ebuild:
+ Version bump.
20 Oct 2011; Tim Harder <radhermit@gentoo.org> exaile-0.3.2.0.ebuild,
exaile-0.3.2.1.ebuild:
diff --git a/media-sound/exaile/exaile-3.4.5.ebuild b/media-sound/exaile/exaile-3.4.5.ebuild
new file mode 100644
index 000000000000..72177a4517fc
--- /dev/null
+++ b/media-sound/exaile/exaile-3.4.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-3.4.5.ebuild,v 1.1 2015/07/27 19:53:59 polynomial-c Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit fdo-mime multilib python-r1
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+ dev-python/gst-python:0.10
+ >=dev-python/pygtk-2.17
+ >=dev-python/pygobject-2.18:2
+ media-libs/gst-plugins-good:0.10
+ >=media-libs/mutagen-1.10
+ media-plugins/gst-plugins-meta:0.10
+ cddb? ( dev-python/cddb-py )
+ libnotify? ( dev-python/notify-python )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+RESTRICT="test" #315589
+
+src_compile() {
+ if use nls; then
+ emake locale
+ fi
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ dodoc FUTURE
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}