summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-23 21:41:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-23 21:41:15 +0000
commit1f457e1434a8e3c1c5cad2c6fb578f3ac6c4a239 (patch)
treef2e31aa34dd9430c4e433a02bda2d50e05cfc99f /media-sound/glmix
parentRemoving old version. (Manifest recommit) (diff)
downloadgentoo-2-1f457e1434a8e3c1c5cad2c6fb578f3ac6c4a239.tar.gz
gentoo-2-1f457e1434a8e3c1c5cad2c6fb578f3ac6c4a239.tar.bz2
gentoo-2-1f457e1434a8e3c1c5cad2c6fb578f3ac6c4a239.zip
fix deps; tidy
Diffstat (limited to 'media-sound/glmix')
-rw-r--r--media-sound/glmix/ChangeLog5
-rw-r--r--media-sound/glmix/glmix-0.1.ebuild26
2 files changed, 16 insertions, 15 deletions
diff --git a/media-sound/glmix/ChangeLog b/media-sound/glmix/ChangeLog
index 4d3bcf556a69..39e3ce4e2fff 100644
--- a/media-sound/glmix/ChangeLog
+++ b/media-sound/glmix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/glmix
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glmix/ChangeLog,v 1.1 2004/08/22 21:47:21 fvdpol Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glmix/ChangeLog,v 1.2 2004/08/23 21:41:15 mr_bones_ Exp $
+
+ 23 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> glmix-0.1.ebuild:
+ fix deps; tidy
*glmix-0.1 (22 Aug 2004)
diff --git a/media-sound/glmix/glmix-0.1.ebuild b/media-sound/glmix/glmix-0.1.ebuild
index 21b27abdc6d8..65c279507deb 100644
--- a/media-sound/glmix/glmix-0.1.ebuild
+++ b/media-sound/glmix/glmix-0.1.ebuild
@@ -1,34 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glmix/glmix-0.1.ebuild,v 1.1 2004/08/22 21:47:21 fvdpol Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glmix/glmix-0.1.ebuild,v 1.2 2004/08/23 21:41:15 mr_bones_ Exp $
DESCRIPTION="A 3D widget for mixing up to eight JACK audio streams down to stereo"
HOMEPAGE="http://www.ecs.soton.ac.uk/~njl98r/code/ladspa/"
SRC_URI="http://www.ecs.soton.ac.uk/~njl98r/code/ladspa/${P}.tar.gz"
-RESTRICT=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
-#first two for WANT_AUTOMAKE/CONF
-DEPEND=">=sys-devel/autoconf-2.58
- >=sys-devel/automake-1.7.2
- >=dev-util/pkgconfig-0.12.0
- virtual/glibc
+S="${WORKDIR}/glmix"
+
+RDEPEND="virtual/libc
virtual/jack
>=x11-libs/gtkglext-1.0.0
>=x11-libs/gtk+-2.0.0"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/automake-1.7.2
+ >=dev-util/pkgconfig-0.12.0"
src_compile() {
- cd ${WORKDIR}/glmix && \
- emake || die
+ emake || die "emake failed"
}
src_install() {
- cd ${WORKDIR}/glmix && \
- dobin glmix
- dodoc COPYING README TODO
+ dobin glmix || die "dobin failed"
+ dodoc README TODO
}