summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-04-06 13:44:35 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-04-06 13:44:35 +0000
commit8823089a416c2f57b8fca1f14facbd2d71d94ab9 (patch)
tree996608937dd8d9800fac987a9c62a00c4560aeb0 /media-sound/lame
parentlittle fixes (diff)
downloadgentoo-2-8823089a416c2f57b8fca1f14facbd2d71d94ab9.tar.gz
gentoo-2-8823089a416c2f57b8fca1f14facbd2d71d94ab9.tar.bz2
gentoo-2-8823089a416c2f57b8fca1f14facbd2d71d94ab9.zip
Gcc 3 fixes
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog7
-rw-r--r--media-sound/lame/files/lame-3.91-gcc3.diff11
-rw-r--r--media-sound/lame/lame-3.91.ebuild10
3 files changed, 26 insertions, 2 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 822b2229f474..3d87050dc255 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.2 2002/03/28 22:23:36 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.3 2002/04/06 13:44:35 gbevin Exp $
+
+ 06 Apr 2002; Geert Bevin <gbevin@gentoo.org> lame-3.91.ebuild,
+ files/lame-3.91-gcc3.diff :
+
+ Little preprocessor fix to help it compile with gcc 3.
*lame-3.91 (28 Mar 2002)
diff --git a/media-sound/lame/files/lame-3.91-gcc3.diff b/media-sound/lame/files/lame-3.91-gcc3.diff
new file mode 100644
index 000000000000..0abfdbd2ae4c
--- /dev/null
+++ b/media-sound/lame/files/lame-3.91-gcc3.diff
@@ -0,0 +1,11 @@
+--- lame-3.91/frontend/rtp.h_copy 2002-04-06 15:37:29.000000000 +0200
++++ lame-3.91/frontend/rtp.h 2002-04-06 15:36:58.000000000 +0200
+@@ -26,7 +26,7 @@
+ int makesocket(char *szAddr,unsigned short port,unsigned char TTL,struct sockaddr_in *sSockAddr);
+ void rtp_output(const char *mp3buffer,int mp3size);
+
+-#ifdef 0
++#if 0
+ int rtp_send (
+ SOCKET s,
+ struct rtpheader *foo,
diff --git a/media-sound/lame/lame-3.91.ebuild b/media-sound/lame/lame-3.91.ebuild
index f2f3881f522e..27171d5c1401 100644
--- a/media-sound/lame/lame-3.91.ebuild
+++ b/media-sound/lame/lame-3.91.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.91.ebuild,v 1.2 2002/03/28 22:23:36 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.91.ebuild,v 1.3 2002/04/06 13:44:35 gbevin Exp $
S=${WORKDIR}/lame-${PV}
DESCRIPTION="LAME Ain't an Mp3 Encoder"
@@ -19,6 +19,14 @@ RDEPEND="virtual/glibc
gtk? ( >=x11-libs/gtk+-1.2.10-r4 )"
# oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/lame-3.91-gcc3.diff || die
+
+}
src_compile() {