summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-12-11 16:22:26 +0000
committerTilman Klar <phoenix@gentoo.org>2002-12-11 16:22:26 +0000
commitdc26700e9968654e7dd560f3e0750c477464a4dc (patch)
tree5ebda760d2bd351f1ccb4a27f6406505ed7d0179 /media-sound/lame
parentVersion bump per Bug#11751 (diff)
downloadgentoo-2-dc26700e9968654e7dd560f3e0750c477464a4dc.tar.gz
gentoo-2-dc26700e9968654e7dd560f3e0750c477464a4dc.tar.bz2
gentoo-2-dc26700e9968654e7dd560f3e0750c477464a4dc.zip
Version bump.
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog11
-rw-r--r--media-sound/lame/files/digest-lame-3.93.11
-rw-r--r--media-sound/lame/lame-3.93.1.ebuild61
3 files changed, 71 insertions, 2 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 3a38354f84f5..84d8aa681077 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for media-sound/lame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.10 2002/12/09 04:26:14 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.11 2002/12/11 16:22:26 phoenix Exp $
-\* Autoupdate keywords (12-6-02)
+*lame-3.93.1 (11 Dec 2002)
+
+ 11 Dec 2002; phoen][x <phoenix@gentoo.org> lame-3.93.1.ebuild,
+ files/digest-lame-3.93.1 :
+ Bumped to new version. Hopefully, the need for these quality problem
+ patches is gone now.
+
+* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
*lame-3.93.0 (23 Nov 2002)
diff --git a/media-sound/lame/files/digest-lame-3.93.1 b/media-sound/lame/files/digest-lame-3.93.1
new file mode 100644
index 000000000000..bc8392a0b0e7
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.93.1
@@ -0,0 +1 @@
+MD5 1b79c08045eafc55e24ebd38d9e84329 lame-3.93.1.tar.gz 1037603
diff --git a/media-sound/lame/lame-3.93.1.ebuild b/media-sound/lame/lame-3.93.1.ebuild
new file mode 100644
index 000000000000..601823be37da
--- /dev/null
+++ b/media-sound/lame/lame-3.93.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.1.ebuild,v 1.1 2002/12/11 16:22:26 phoenix Exp $
+
+IUSE="gtk"
+
+inherit libtool eutils
+
+DESCRIPTION="LAME Ain't an Mp3 Encoder"
+SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
+HOMEPAGE="http://www.mp3dev.org/mp3/"
+
+DEPEND="virtual/glibc
+ x86? ( dev-lang/nasm )
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+# this release completely removed oggvorbis support as it was too outdated.
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ if [ "`use gtk`" ] ; then
+ myconf="${myconf} --enable-mp3x"
+ fi
+ if [ "${DEBUG}" ] ; then
+ myconf="${myconf} --enable-debug=yes"
+ else
+ myconf="${myconf} --enable-debug=no"
+ fi
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-shared \
+ --enable-nasm \
+ --enable-mp3rtp \
+ --enable-extopt=full \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ pkghtmldir=${D}/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
+ dohtml -r ./
+}
+