summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-16 16:07:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-16 16:07:21 +0000
commit7df145a529baa604a8f625ad7bf43b954e25bd2f (patch)
tree73c469c4be392c865f95d3337850067d897248ca /media-sound/lash
parentx86 stable, bug #202458 (diff)
downloadgentoo-2-7df145a529baa604a8f625ad7bf43b954e25bd2f.tar.gz
gentoo-2-7df145a529baa604a8f625ad7bf43b954e25bd2f.tar.bz2
gentoo-2-7df145a529baa604a8f625ad7bf43b954e25bd2f.zip
version bump
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'media-sound/lash')
-rw-r--r--media-sound/lash/ChangeLog7
-rw-r--r--media-sound/lash/files/digest-lash-0.5.43
-rw-r--r--media-sound/lash/lash-0.5.4.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/media-sound/lash/ChangeLog b/media-sound/lash/ChangeLog
index dd43157b7765..df5017f45aa3 100644
--- a/media-sound/lash/ChangeLog
+++ b/media-sound/lash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.13 2007/11/01 20:56:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.14 2007/12/16 16:07:20 aballier Exp $
+
+*lash-0.5.4 (16 Dec 2007)
+
+ 16 Dec 2007; Alexis Ballier <aballier@gentoo.org> +lash-0.5.4.ebuild:
+ version bump
01 Nov 2007; Raúl Porcel <armin76@gentoo.org> lash-0.5.3.ebuild:
Add ~alpha wrt #196587, thanks to Tobias Klausmann for testing
diff --git a/media-sound/lash/files/digest-lash-0.5.4 b/media-sound/lash/files/digest-lash-0.5.4
new file mode 100644
index 000000000000..2c1f74a1010c
--- /dev/null
+++ b/media-sound/lash/files/digest-lash-0.5.4
@@ -0,0 +1,3 @@
+MD5 8eeb7e91f9127d7d9fc6ec076cbe14ed lash-0.5.4.tar.gz 623469
+RMD160 251a20c0597b8ec6fac2a39bab1d18ab5c017f40 lash-0.5.4.tar.gz 623469
+SHA256 105a7da84415c4725c6bcad28e70f23aeb4534f94fc80ca262b6a2cef2226c16 lash-0.5.4.tar.gz 623469
diff --git a/media-sound/lash/lash-0.5.4.ebuild b/media-sound/lash/lash-0.5.4.ebuild
new file mode 100644
index 000000000000..3af33f167c00
--- /dev/null
+++ b/media-sound/lash/lash-0.5.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4.ebuild,v 1.1 2007/12/16 16:07:20 aballier Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="LASH Audio Session Handler"
+HOMEPAGE="http://www.nongnu.org/lash/"
+SRC_URI="http://download.savannah.gnu.org/releases/lash/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug gtk python"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ media-sound/jack-audio-connection-kit
+ dev-libs/libxml2
+ gtk? ( >=x11-libs/gtk+-2.0 )
+ python? ( dev-lang/python )
+ || ( sys-libs/readline sys-libs/libedit )"
+
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build ${CATEGORY}/${PN} with ALSA support you"
+ eerror "need to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ elibtoolize
+}
+
+src_compile() {
+ local myconf
+
+ # Yet-another-broken-configure: --enable-pylash would disable it.
+ use python || myconf="${myconf} --disable-pylash"
+
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable gtk gtk2) \
+ $(use_enable debug) \
+ ${myconf} \
+ --disable-dependency-tracking \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}