summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-26 15:37:51 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-26 15:37:51 +0000
commitf24c0b487485e18f53ed29b47bbea1c99834dcb5 (patch)
tree11f688bb9fc10c07fe01b32b3ea3759657cc45db /media-sound/last-exit
parentMarking enigmail-0.95.7-r2 ppc64 for bug 246628 (diff)
downloadgentoo-2-f24c0b487485e18f53ed29b47bbea1c99834dcb5.tar.gz
gentoo-2-f24c0b487485e18f53ed29b47bbea1c99834dcb5.tar.bz2
gentoo-2-f24c0b487485e18f53ed29b47bbea1c99834dcb5.zip
Fix bug 248892. Also add patch to build against system notify-sharp. Add deps permissive of gtk-sharp-2.12.6.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'media-sound/last-exit')
-rw-r--r--media-sound/last-exit/ChangeLog9
-rw-r--r--media-sound/last-exit/files/last-exit-notify-sharp.patch60
-rw-r--r--media-sound/last-exit/last-exit-6-r1.ebuild61
3 files changed, 129 insertions, 1 deletions
diff --git a/media-sound/last-exit/ChangeLog b/media-sound/last-exit/ChangeLog
index 1f72d165a4cc..3e938f925153 100644
--- a/media-sound/last-exit/ChangeLog
+++ b/media-sound/last-exit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/last-exit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/ChangeLog,v 1.16 2008/07/23 20:11:26 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/ChangeLog,v 1.17 2008/11/26 15:37:51 loki_val Exp $
+
+*last-exit-6-r1 (26 Nov 2008)
+
+ 26 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/last-exit-notify-sharp.patch, +last-exit-6-r1.ebuild:
+ Fix bug 248892. Also add patch to build against system notify-sharp. Add
+ deps permissive of gtk-sharp-2.12.6.
*last-exit-6 (23 Jul 2008)
diff --git a/media-sound/last-exit/files/last-exit-notify-sharp.patch b/media-sound/last-exit/files/last-exit-notify-sharp.patch
new file mode 100644
index 000000000000..5a0c02f077dc
--- /dev/null
+++ b/media-sound/last-exit/files/last-exit-notify-sharp.patch
@@ -0,0 +1,60 @@
+--- trunk/configure.ac 2008/03/21 16:15:50 167
++++ trunk/configure.ac 2008/03/26 08:08:52 168
+@@ -50,6 +50,13 @@
+ fi
+ AM_CONDITIONAL(EXTERNAL_DBUS, test "x$have_external_dbus" = "xyes")
+
++PKG_CHECK_MODULES(NOTIFY_SHARP, notify-sharp, have_external_notify_sharp="yes", have_external_notify_sharp="no")
++if test "x$have_external_notify_sharp" != "xyes"; then
++ AC_MSG_RESULT([using internal copy])
++fi
++AM_CONDITIONAL(EXTERNAL_NOTIFY_SHARP, test "x$have_external_notify_sharp" = "xyes")
++
++
+ AC_PATH_PROG(MCS, gmcs)
+ if test x$MCS = x; then
+ AC_MSG_ERROR(You need mcs)
+--- trunk/src/Makefile.am 2008/03/21 16:15:50 167
++++ trunk/src/Makefile.am 2008/03/26 08:08:52 168
+@@ -72,8 +72,12 @@
+ XMLRPC_ASSEMBLIES = \
+ -r:${DIR_XMLRPC}/XmlRpcCS.dll
+
++if EXTERNAL_NOTIFY_SHARP
++NOTIFY_ASSEMBLIES = $(NOTIFY_SHARP_LIBS)
++else
+ NOTIFY_ASSEMBLIES = \
+ -r:$(DIR_NOTIFY)/notify-sharp.dll
++endif
+
+ LASTEXIT_RESOURCES = \
+ -resource:$(top_srcdir)/data/glade/FindStation.glade \
+--- trunk/notify-sharp/Makefile.am 2008/03/21 16:15:50 167
++++ trunk/notify-sharp/Makefile.am 2008/03/26 08:08:52 168
+@@ -1,13 +1,13 @@
+ NOTIFY_ASSEMBLY = notify-sharp.dll
++NOTIFY_SRC = \
++ $(srcdir)/Global.cs \
++ $(srcdir)/Notification.cs
+
++if !EXTERNAL_NOTIFY_SHARP
+ notifydir = $(pkglibdir)
+ notify_SCRIPTS = \
+ $(NOTIFY_ASSEMBLY)
+
+-NOTIFY_SRC = \
+- $(srcdir)/Global.cs \
+- $(srcdir)/Notification.cs
+-
+ if EXTERNAL_DBUS
+ DBUS_ASSEMBLIES = $(DBUS_LIBS)
+ else
+@@ -21,6 +21,8 @@
+ $(NOTIFY_ASSEMBLY): $(NOTIFY_SRC)
+ $(MCS) -target:library -out:$@ $(DBUS_ASSEMBLIES) $(GTKSHARP_LIBS) $(NOTIFY_SRC)
+
++endif
++
+ EXTRA_DIST = $(NOTIFY_SRC)
+ DISTCLEANFILES = $(NOTIFY_ASSEMBLY) $(NOTIFY_ASSEMBLY).mdb
+ MAINTAINERCLEANFILES = Makefile.in
diff --git a/media-sound/last-exit/last-exit-6-r1.ebuild b/media-sound/last-exit/last-exit-6-r1.ebuild
new file mode 100644
index 000000000000..907e2a32349d
--- /dev/null
+++ b/media-sound/last-exit/last-exit-6-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/last-exit-6-r1.ebuild,v 1.1 2008/11/26 15:37:51 loki_val Exp $
+
+EAPI=2
+
+inherit mono gnome2 eutils autotools
+
+DESCRIPTION="Gnome/GTK+ alternative to the last.fm player"
+HOMEPAGE="http://lastexit-player.org/"
+SRC_URI="http://lastexit-player.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.6
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10
+ >=media-plugins/gst-plugins-mad-0.10
+ >=media-plugins/gst-plugins-gconf-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ >=dev-lang/mono-1.0
+ || ( >=dev-dotnet/gtk-sharp-2.12.6[glade] ( >=dev-dotnet/gtk-sharp-2 >=dev-dotnet/glade-sharp-2 ) )
+ >=dev-dotnet/gnome-sharp-2
+ >=dev-dotnet/gnomevfs-sharp-2
+ dev-dotnet/notify-sharp
+ >=dev-dotnet/gconf-sharp-2
+ >=dev-libs/dbus-glib-0.71
+ >=dev-dotnet/dbus-sharp-0.6.0
+ >=dev-dotnet/dbus-glib-sharp-0.4.1
+ >=x11-libs/libsexy-0.1.7"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-schemas-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}/${PN}-notify-sharp.patch"
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}