summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-26 23:40:48 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-26 23:40:48 +0000
commit56a566298f0091ccf3fd6cd2467ece06cb3f26ea (patch)
tree8648fd291041ea905d29dbdd542a3235898f9e0e /media-sound/lilycomp/lilycomp-1.0.2-r1.ebuild
parentremoved old revision. (diff)
downloadgentoo-2-56a566298f0091ccf3fd6cd2467ece06cb3f26ea.tar.gz
gentoo-2-56a566298f0091ccf3fd6cd2467ece06cb3f26ea.tar.bz2
gentoo-2-56a566298f0091ccf3fd6cd2467ece06cb3f26ea.zip
Revbump. Use EAPI=2 and use dependencies.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'media-sound/lilycomp/lilycomp-1.0.2-r1.ebuild')
-rw-r--r--media-sound/lilycomp/lilycomp-1.0.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/lilycomp/lilycomp-1.0.2-r1.ebuild b/media-sound/lilycomp/lilycomp-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..db82971a539a
--- /dev/null
+++ b/media-sound/lilycomp/lilycomp-1.0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilycomp/lilycomp-1.0.2-r1.ebuild,v 1.1 2008/10/26 23:40:48 hawking Exp $
+
+EAPI="2"
+inherit python
+
+MY_P="${P/-/.}"
+
+DESCRIPTION="graphical note entry program for use with LilyPond"
+HOMEPAGE="http://lilycomp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python[tk]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ newbin lilycomp.py lilycomp || die "newbin failed"
+ dohtml *.html
+ dodoc [[:upper:]]*
+}