summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-05 18:13:53 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-05 18:13:53 +0000
commitb3bf268bc44af6202fe0308f6177ce63ed47d255 (patch)
treeb77ef5e10758a40dbbe65f6be7b3a3b89a9a8f2d /media-sound/lilypond
parentold (diff)
downloadgentoo-2-b3bf268bc44af6202fe0308f6177ce63ed47d255.tar.gz
gentoo-2-b3bf268bc44af6202fe0308f6177ce63ed47d255.tar.bz2
gentoo-2-b3bf268bc44af6202fe0308f6177ce63ed47d255.zip
Fix sandbox issue when not building docs (bug #434002 by Gerard Neil).
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/ChangeLog6
-rw-r--r--media-sound/lilypond/files/lilypond-2.16.0-tex-docs.patch20
-rw-r--r--media-sound/lilypond/lilypond-2.16.0.ebuild5
3 files changed, 28 insertions, 3 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index 677794b211a5..319ba8661299 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lilypond
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.124 2012/09/01 07:48:25 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.125 2012/09/05 18:13:53 radhermit Exp $
+
+ 05 Sep 2012; Tim Harder <radhermit@gentoo.org> lilypond-2.16.0.ebuild,
+ +files/lilypond-2.16.0-tex-docs.patch:
+ Fix sandbox issue when not building docs (bug #434002 by Gerard Neil).
*lilypond-2.17.1 (01 Sep 2012)
diff --git a/media-sound/lilypond/files/lilypond-2.16.0-tex-docs.patch b/media-sound/lilypond/files/lilypond-2.16.0-tex-docs.patch
new file mode 100644
index 000000000000..39c3dbd02ea9
--- /dev/null
+++ b/media-sound/lilypond/files/lilypond-2.16.0-tex-docs.patch
@@ -0,0 +1,20 @@
+--- lilypond-2.16.0/GNUmakefile.in
++++ lilypond-2.16.0/GNUmakefile.in
+@@ -5,7 +5,7 @@
+ SUBDIRS = python scripts \
+ flower lily \
+ mf ly \
+- tex ps scm \
++ ps scm \
+ po make \
+ elisp vim \
+ input \
+@@ -14,7 +14,7 @@
+
+ ## this convoluted construction is necessary, since we don't know the
+ ## value of DOCUMENTATION here.
+-documentation-dir=$(if $(findstring no,$(DOCUMENTATION)),,Documentation)
++documentation-dir=$(if $(findstring no,$(DOCUMENTATION)),,Documentation tex)
+
+ SCRIPTS = configure autogen.sh smart-autogen.sh smart-configure.sh
+ README_FILES = COPYING COPYING.FDL DEDICATION ROADMAP THANKS HACKING \
diff --git a/media-sound/lilypond/lilypond-2.16.0.ebuild b/media-sound/lilypond/lilypond-2.16.0.ebuild
index b6428832c83d..1164e4951bd8 100644
--- a/media-sound/lilypond/lilypond-2.16.0.ebuild
+++ b/media-sound/lilypond/lilypond-2.16.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.16.0.ebuild,v 1.1 2012/08/26 19:41:21 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.16.0.ebuild,v 1.2 2012/09/05 18:13:53 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="2"
-inherit elisp-common python autotools
+inherit elisp-common python autotools eutils
DESCRIPTION="GNU Music Typesetter"
SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
@@ -44,6 +44,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-tex-docs.patch
if ! use vim-syntax ; then
sed -i -e "s/vim//" GNUmakefile.in || die
fi