summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2012-11-23 01:28:57 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2012-11-23 01:28:57 +0000
commitcad5b02af7fe56f683c2236ae20b460a170f4d6a (patch)
treee1380ccc75922be66e5e8339c2cab191913aefef /media-sound/marrie
parentIntroduce 0.26 - 437140 (diff)
downloadgentoo-2-cad5b02af7fe56f683c2236ae20b460a170f4d6a.tar.gz
gentoo-2-cad5b02af7fe56f683c2236ae20b460a170f4d6a.tar.bz2
gentoo-2-cad5b02af7fe56f683c2236ae20b460a170f4d6a.zip
Use distutils.eclass instead of distutils-r1.eclass. Add live ebuild.
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/marrie')
-rw-r--r--media-sound/marrie/ChangeLog9
-rw-r--r--media-sound/marrie/marrie-0.3-r1.ebuild51
-rw-r--r--media-sound/marrie/marrie-0.3.ebuild29
-rw-r--r--media-sound/marrie/marrie-9999.ebuild51
4 files changed, 110 insertions, 30 deletions
diff --git a/media-sound/marrie/ChangeLog b/media-sound/marrie/ChangeLog
index 2790f9a0a0bd..3e3395bb75c6 100644
--- a/media-sound/marrie/ChangeLog
+++ b/media-sound/marrie/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/marrie
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/marrie/ChangeLog,v 1.1 2012/11/22 04:39:08 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/marrie/ChangeLog,v 1.2 2012/11/23 01:28:57 rafaelmartins Exp $
+
+*marrie-9999 (23 Nov 2012)
+*marrie-0.3-r1 (23 Nov 2012)
+
+ 23 Nov 2012; Rafael G. Martins <rafaelmartins@gentoo.org> -marrie-0.3.ebuild,
+ +marrie-0.3-r1.ebuild, +marrie-9999.ebuild:
+ Use distutils.eclass instead of distutils-r1.eclass. Add live ebuild.
*marrie-0.3 (22 Nov 2012)
diff --git a/media-sound/marrie/marrie-0.3-r1.ebuild b/media-sound/marrie/marrie-0.3-r1.ebuild
new file mode 100644
index 000000000000..3539c414dc9e
--- /dev/null
+++ b/media-sound/marrie/marrie-0.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/marrie/marrie-0.3-r1.ebuild,v 1.1 2012/11/23 01:28:57 rafaelmartins Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 2.6 3.*"
+
+HG_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ HG_ECLASS="mercurial"
+ EHG_REPO_URI="http://hg.rafaelmartins.eng.br/marrie/"
+ EHG_REVISION="default"
+fi
+
+inherit distutils ${HG_ECLASS}
+
+DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
+HOMEPAGE="http://projects.rafaelmartins.eng.br/marrie/"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="virtual/python-argparse
+ dev-python/feedparser"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ rst2html.py README.rst marrie.html || die "rst2html.py failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml marrie.html
+ fi
+}
diff --git a/media-sound/marrie/marrie-0.3.ebuild b/media-sound/marrie/marrie-0.3.ebuild
deleted file mode 100644
index 170dc63ec434..000000000000
--- a/media-sound/marrie/marrie-0.3.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/marrie/marrie-0.3.ebuild,v 1.1 2012/11/22 04:39:08 rafaelmartins Exp $
-
-EAPI=4
-PYTHON_COMPAT=(python2_7)
-
-inherit distutils-r1
-
-DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
-HOMEPAGE="http://projects.rafaelmartins.eng.br/marrie/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="virtual/python-argparse
- dev-python/feedparser"
-DEPEND="${RDEPEND}
- dev-python/docutils"
-
-DOCS_HTML=(README.html)
-
-src_compile() {
- rst2html.py README.rst README.html
- distutils-r1_src_compile
-}
diff --git a/media-sound/marrie/marrie-9999.ebuild b/media-sound/marrie/marrie-9999.ebuild
new file mode 100644
index 000000000000..903a09da7490
--- /dev/null
+++ b/media-sound/marrie/marrie-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/marrie/marrie-9999.ebuild,v 1.1 2012/11/23 01:28:57 rafaelmartins Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 2.6 3.*"
+
+HG_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ HG_ECLASS="mercurial"
+ EHG_REPO_URI="http://hg.rafaelmartins.eng.br/marrie/"
+ EHG_REVISION="default"
+fi
+
+inherit distutils ${HG_ECLASS}
+
+DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
+HOMEPAGE="http://projects.rafaelmartins.eng.br/marrie/"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="virtual/python-argparse
+ dev-python/feedparser"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ rst2html.py README.rst marrie.html || die "rst2html.py failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml marrie.html
+ fi
+}