summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-03 13:05:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-03 13:05:15 +0000
commit60681a86260bba3a2a372360ea656a48a3f103df (patch)
tree697f6d225dc263e82d734aeaaab41b3a495b4f56 /media-sound/mp3cat/mp3cat-0.4.ebuild
parentVarious issues (diff)
downloadgentoo-2-60681a86260bba3a2a372360ea656a48a3f103df.tar.gz
gentoo-2-60681a86260bba3a2a372360ea656a48a3f103df.tar.bz2
gentoo-2-60681a86260bba3a2a372360ea656a48a3f103df.zip
Quoting
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mp3cat/mp3cat-0.4.ebuild')
-rw-r--r--media-sound/mp3cat/mp3cat-0.4.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/media-sound/mp3cat/mp3cat-0.4.ebuild b/media-sound/mp3cat/mp3cat-0.4.ebuild
index 026879a1d3fa..7dc906e50b35 100644
--- a/media-sound/mp3cat/mp3cat-0.4.ebuild
+++ b/media-sound/mp3cat/mp3cat-0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3cat/mp3cat-0.4.ebuild,v 1.4 2006/12/11 21:47:20 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3cat/mp3cat-0.4.ebuild,v 1.5 2009/08/03 13:05:15 ssuominen Exp $
inherit toolchain-funcs
@@ -15,8 +15,9 @@ IUSE=""
src_unpack() {
unpack ${A}
- cd ${S}
- sed -i -e 's:cc -o:${CC} ${CFLAGS} ${LDFLAGS} -o:' Makefile
+ cd "${S}"
+ sed -i -e 's:cc -o:${CC} ${CFLAGS} ${LDFLAGS} -o:' \
+ Makefile || die "sed failed"
}
src_compile() {
@@ -24,5 +25,6 @@ src_compile() {
}
src_install() {
- dobin mp3cat mp3log mp3log-conf mp3dirclean mp3http mp3stream-conf
+ dobin mp3cat mp3log mp3log-conf mp3dirclean mp3http \
+ mp3stream-conf || die "sed failed"
}