summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-03-19 23:19:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-03-19 23:19:01 +0000
commit372cd2684d98d42fb550dea12cd10632ea326801 (patch)
tree883942b71e9706bb20caf9cf6e1d7cd7716afd03 /media-sound/mp3diags
parentRemove old masks. (diff)
downloadgentoo-2-372cd2684d98d42fb550dea12cd10632ea326801.tar.gz
gentoo-2-372cd2684d98d42fb550dea12cd10632ea326801.tar.bz2
gentoo-2-372cd2684d98d42fb550dea12cd10632ea326801.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'media-sound/mp3diags')
-rw-r--r--media-sound/mp3diags/ChangeLog9
-rw-r--r--media-sound/mp3diags/mp3diags-1.2.02.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/media-sound/mp3diags/ChangeLog b/media-sound/mp3diags/ChangeLog
index 83a724932092..4651f3df51d8 100644
--- a/media-sound/mp3diags/ChangeLog
+++ b/media-sound/mp3diags/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mp3diags
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3diags/ChangeLog,v 1.18 2014/03/28 16:19:36 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3diags/ChangeLog,v 1.19 2015/03/19 23:19:01 mrueg Exp $
+
+*mp3diags-1.2.02 (19 Mar 2015)
+
+ 19 Mar 2015; Manuel Rüger <mrueg@gentoo.org> +mp3diags-1.2.02.ebuild:
+ Version bump.
*mp3diags-1.2.01 (28 Mar 2014)
diff --git a/media-sound/mp3diags/mp3diags-1.2.02.ebuild b/media-sound/mp3diags/mp3diags-1.2.02.ebuild
new file mode 100644
index 000000000000..a7faa45977bb
--- /dev/null
+++ b/media-sound/mp3diags/mp3diags-1.2.02.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3diags/mp3diags-1.2.02.ebuild,v 1.1 2015/03/19 23:19:01 mrueg Exp $
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+MY_PN=MP3Diags
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Qt-based MP3 diagnosis and repair tool"
+HOMEPAGE="http://mp3diags.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/boost-1.37
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:4
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dobin bin/${MY_PN}
+ dodoc changelog.txt
+
+ local size
+ for size in 16 22 24 32 36 40 48; do
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins desktop/${MY_PN}${size}.png ${MY_PN}.png
+ done
+ domenu desktop/${MY_PN}.desktop
+}