summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-01-19 00:37:07 +0000
committerChristoph Mende <angelos@gentoo.org>2009-01-19 00:37:07 +0000
commita9eb0df65b7a88c98512493750c837452198ebdb (patch)
tree08f36a19e4c88ae516531e32648a403ba445b674 /media-sound/mpdscribble
parentwhitespace (diff)
downloadgentoo-2-a9eb0df65b7a88c98512493750c837452198ebdb.tar.gz
gentoo-2-a9eb0df65b7a88c98512493750c837452198ebdb.tar.bz2
gentoo-2-a9eb0df65b7a88c98512493750c837452198ebdb.zip
Version bump and remove -m from stop() in mpdscribble.rc (bug 254302)
(Portage version: 2.2_rc22/cvs/Linux 2.6.29-rc2 x86_64)
Diffstat (limited to 'media-sound/mpdscribble')
-rw-r--r--media-sound/mpdscribble/ChangeLog8
-rw-r--r--media-sound/mpdscribble/files/mpdscribble.rc2
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.16.ebuild30
3 files changed, 38 insertions, 2 deletions
diff --git a/media-sound/mpdscribble/ChangeLog b/media-sound/mpdscribble/ChangeLog
index 943578841a95..754408f75f27 100644
--- a/media-sound/mpdscribble/ChangeLog
+++ b/media-sound/mpdscribble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpdscribble
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.22 2009/01/07 20:38:28 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.23 2009/01/19 00:37:07 angelos Exp $
+
+*mpdscribble-0.16 (19 Jan 2009)
+
+ 19 Jan 2009; Christoph Mende <angelos@gentoo.org> files/mpdscribble.rc,
+ +mpdscribble-0.16.ebuild:
+ Version bump and remove -m from stop() in mpdscribble.rc (bug 254302)
*mpdscribble-0.15 (07 Jan 2009)
diff --git a/media-sound/mpdscribble/files/mpdscribble.rc b/media-sound/mpdscribble/files/mpdscribble.rc
index 638e2a2ccc82..41597a12d09d 100644
--- a/media-sound/mpdscribble/files/mpdscribble.rc
+++ b/media-sound/mpdscribble/files/mpdscribble.rc
@@ -14,7 +14,7 @@ start () {
stop () {
ebegin "Stopping Music Player Daemon Audioscrobbler client"
- start-stop-daemon --stop --quiet -p /var/run/mpdscribble.pid -m --exec /usr/bin/mpdscribble || eerror "mpdscribble is not running"
+ start-stop-daemon --stop --quiet -p /var/run/mpdscribble.pid --exec /usr/bin/mpdscribble || eerror "mpdscribble is not running"
rm -f /var/run/mpdscribble.pid
eend $?
}
diff --git a/media-sound/mpdscribble/mpdscribble-0.16.ebuild b/media-sound/mpdscribble/mpdscribble-0.16.ebuild
new file mode 100644
index 000000000000..a0944d094a39
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.16.ebuild,v 1.1 2009/01/19 00:37:07 angelos Exp $
+
+EAPI=1
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:Mpdscribble"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ || ( >=dev-libs/glib-2.16:2
+ dev-libs/libgcrypt )
+ net-libs/libsoup:2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ chmod 600 "${D}"/etc/mpdscribble.conf
+ dodoc AUTHORS NEWS README
+ rm -r -f "${D}"/usr/share/doc/${PN}
+ dodir /var/cache/mpdscribble
+}