summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-17 20:46:13 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-17 20:46:13 +0000
commit99b54ca3e2b7dba68df62bcfccdd07204f7a940c (patch)
tree71c1a882c1a39cb3a976d68b6ba9ae490e5b551f /media-sound/nted/nted-1.10.18-r2.ebuild
parentDrop epunt_cxx as this no longer needs it. (diff)
downloadgentoo-2-99b54ca3e2b7dba68df62bcfccdd07204f7a940c.tar.gz
gentoo-2-99b54ca3e2b7dba68df62bcfccdd07204f7a940c.tar.bz2
gentoo-2-99b54ca3e2b7dba68df62bcfccdd07204f7a940c.zip
Revision bump: EAPI 5, add missing lilypond tremolo export patch, wrt bug #437540 and #457400
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'media-sound/nted/nted-1.10.18-r2.ebuild')
-rw-r--r--media-sound/nted/nted-1.10.18-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/nted/nted-1.10.18-r2.ebuild b/media-sound/nted/nted-1.10.18-r2.ebuild
new file mode 100644
index 000000000000..9dc29eacf1e2
--- /dev/null
+++ b/media-sound/nted/nted-1.10.18-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.10.18-r2.ebuild,v 1.1 2013/02/17 20:46:13 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="WYSIWYG score editor for GTK+"
+HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/sources/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2 NTED_FONT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug nls"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ >=media-libs/freetype-2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ nls? ( sys-devel/gettext )"
+
+DOCS=( ABOUT_THE_EXAMPLES.TXT AUTHORS FAQ README )
+
+src_prepare() {
+ # bug #424291
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ # bug #437540
+ epatch "${FILESDIR}"/${P}-lilypond.patch
+ epatch "${FILESDIR}"/${P}-lilypond-tremolo.patch
+}
+
+src_configure() {
+ # Trick ./configure to believe we have gnome-extra/yelp installed.
+ has_version gnome-extra/yelp || export ac_cv_path_YELP="$(type -P true)"
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_with doc)
+}