summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-30 22:20:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-30 22:20:42 +0000
commit575f7324ef1cb3a4674bfa9089e915914583a844 (patch)
tree691420976ec295ef757d0ea19a046d7eb0c33411 /media-sound/nted
parentInitial commit of dbmodel application (diff)
downloadgentoo-2-575f7324ef1cb3a4674bfa9089e915914583a844.tar.gz
gentoo-2-575f7324ef1cb3a4674bfa9089e915914583a844.tar.bz2
gentoo-2-575f7324ef1cb3a4674bfa9089e915914583a844.zip
Initial commit of nted score editor. Fixes bug 244716
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/nted')
-rw-r--r--media-sound/nted/ChangeLog13
-rw-r--r--media-sound/nted/metadata.xml17
-rw-r--r--media-sound/nted/nted-1.6.0.ebuild36
3 files changed, 66 insertions, 0 deletions
diff --git a/media-sound/nted/ChangeLog b/media-sound/nted/ChangeLog
new file mode 100644
index 000000000000..d8a1f55d5e9b
--- /dev/null
+++ b/media-sound/nted/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-sound/nted
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.1 2009/06/30 22:20:42 hwoarang Exp $
+
+*nted-1.6.0 (30 Jun 2009)
+
+ 30 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +nted-1.6.0.ebuild,
+ +metadata.xml:
+ Initial commit of nted score editor. Fixes bug 244716. adding Matthias
+ Vill
+ <gentoo@cconstruct.de> as proxy maintainer. Thanks to Dominik Kozaczko
+ <dominik@kozaczko.info> for the initial ebuild.
+
diff --git a/media-sound/nted/metadata.xml b/media-sound/nted/metadata.xml
new file mode 100644
index 000000000000..79531f8f111a
--- /dev/null
+++ b/media-sound/nted/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<maintainer>
+<email>gentoo@cconstruct.de</email>
+<name>Matthias Vill</name>
+<description>Proxy maintainer</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-sound/nted/nted-1.6.0.ebuild b/media-sound/nted/nted-1.6.0.ebuild
new file mode 100644
index 000000000000..194c73b97997
--- /dev/null
+++ b/media-sound/nted/nted-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.6.0.ebuild,v 1.1 2009/06/30 22:20:42 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="WYSIWYG score editor for GTK+2"
+HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls debug"
+RDEPEND="doc? ( gnome-extra/yelp app-text/xmlto )
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+
+src_configure() {
+ econf $(use_with doc) \
+ $(use_enable debug) \
+ $(use_enable nls) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ABOUT_* ChangeLog FAQ NEWS README || die "dodoc failed"
+ doman "man/${PN}.1" || die "doman failed"
+}