summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-07-10 23:14:43 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-07-10 23:14:43 +0000
commit3bd6c293dd581bf6c5ac389dd1d40ce20383a4a2 (patch)
tree068a2bc9af555892450792821fde696553c2db18 /media-sound/pithos/files
parentFix for CVE-2013-2230. bug #476094 (diff)
downloadgentoo-2-3bd6c293dd581bf6c5ac389dd1d40ce20383a4a2.tar.gz
gentoo-2-3bd6c293dd581bf6c5ac389dd1d40ce20383a4a2.tar.bz2
gentoo-2-3bd6c293dd581bf6c5ac389dd1d40ce20383a4a2.zip
New package: Pithos - A Pandora Radio Client for Linux
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 5C350883)
Diffstat (limited to 'media-sound/pithos/files')
-rw-r--r--media-sound/pithos/files/pithos-detect-datadir.patch37
-rw-r--r--media-sound/pithos/files/setup.py37
2 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/pithos/files/pithos-detect-datadir.patch b/media-sound/pithos/files/pithos-detect-datadir.patch
new file mode 100644
index 000000000000..018f8e368fa3
--- /dev/null
+++ b/media-sound/pithos/files/pithos-detect-datadir.patch
@@ -0,0 +1,37 @@
+diff --git a/pithos/pithosconfig.py b/pithos/pithosconfig.py
+index dd46d2b..f82b458 100644
+--- a/pithos/pithosconfig.py
++++ b/pithos/pithosconfig.py
+@@ -1,22 +1,25 @@
+ # -*- coding: utf-8; tab-width: 4; indent-tabs-mode: nil; -*-
+ ### BEGIN LICENSE
+ # Copyright (C) 2010-2012 Kevin Mehall <km@kevinmehall.net>
+-#This program is free software: you can redistribute it and/or modify it
+-#under the terms of the GNU General Public License version 3, as published
++#This program is free software: you can redistribute it and/or modify it
++#under the terms of the GNU General Public License version 3, as published
+ #by the Free Software Foundation.
+ #
+-#This program is distributed in the hope that it will be useful, but
+-#WITHOUT ANY WARRANTY; without even the implied warranties of
+-#MERCHANTABILITY, SATISFACTORY QUALITY, or FITNESS FOR A PARTICULAR
++#This program is distributed in the hope that it will be useful, but
++#WITHOUT ANY WARRANTY; without even the implied warranties of
++#MERCHANTABILITY, SATISFACTORY QUALITY, or FITNESS FOR A PARTICULAR
+ #PURPOSE. See the GNU General Public License for more details.
+ #
+-#You should have received a copy of the GNU General Public License along
++#You should have received a copy of the GNU General Public License along
+ #with this program. If not, see <http://www.gnu.org/licenses/>.
+ ### END LICENSE
+
+ # where your project will head for your data (for instance, images and ui files)
+ # by default, this is ../data, relative your trunk layout
+-__pithos_data_directory__ = '../data/'
++from os.path import isdir, normpath, join
++__pithos_data_directory__ = (normpath(join(__file__, '../data/'))
++ if isdir(join(__file__, '../data/'))
++ else '/usr/share/pithos')
+ __license__ = 'GPL-3'
+
+ VERSION = '0.3.17'
diff --git a/media-sound/pithos/files/setup.py b/media-sound/pithos/files/setup.py
new file mode 100644
index 000000000000..0d5776ae4a98
--- /dev/null
+++ b/media-sound/pithos/files/setup.py
@@ -0,0 +1,37 @@
+# replacement for setup.py for pithos as the included one is.. less than ideal
+
+from os import walk
+from glob import glob
+from os.path import join
+from setuptools import setup, find_packages
+
+DATA_DIR = '/usr/share/pithos/'
+ICON_DIR = '/usr/share/icons/hicolor/'
+APP_DIR = '/usr/share/applications'
+
+datadir = 'data'
+datadirs = ['ui', 'media']
+icondir = 'data/icons'
+bindir = 'bin'
+
+datafiles = [[(join(DATA_DIR, root.partition(datadir)[2].lstrip('/')), [join(root, f) for f in files])
+ for root, dirs, files in walk(join(datadir, data))][0] for data in datadirs]
+
+datafiles += ([(join(ICON_DIR, root.partition(icondir)[2].lstrip('/')), [join(root, f) for f in files])
+ for root, dirs, files in walk(icondir)])
+
+datafiles += [(APP_DIR, glob('*.desktop'))]
+
+setup(
+ name='pithos',
+ version='0.3',
+ ext_modules=[],
+ license='GPL-3',
+ author='Kevin Mehall',
+ author_email='km@kevinmehall.net',
+ description='Pandora.com client for the GNOME desktop',
+ packages=find_packages(),
+ url='https://launchpad.net/pithos',
+ data_files=datafiles,
+ scripts=glob('bin/*'),
+)