summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-21 15:24:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-21 15:24:00 +0000
commite38c7e9679ee05927281115b8d7bad2ab62cda53 (patch)
treebe34df0b8e16c0b07f0110626a30f98bdec7a3f9 /media-sound/qjackctl/qjackctl-0.3.9.ebuild
parentVersion bump (diff)
downloadgentoo-2-e38c7e9679ee05927281115b8d7bad2ab62cda53.tar.gz
gentoo-2-e38c7e9679ee05927281115b8d7bad2ab62cda53.tar.bz2
gentoo-2-e38c7e9679ee05927281115b8d7bad2ab62cda53.zip
version bump
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qjackctl/qjackctl-0.3.9.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.3.9.ebuild b/media-sound/qjackctl/qjackctl-0.3.9.ebuild
new file mode 100644
index 000000000000..b884a4f284d2
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.9.ebuild,v 1.1 2012/05/21 15:24:00 aballier Exp $
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa dbus debug portaudio"
+
+RDEPEND="
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( x11-libs/qt-dbus:4 )
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README TODO TRANSLATORS"
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable portaudio)
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak
+}
+
+src_compile() {
+ emake -f ${PN}.mak
+ lupdate ${PN}.pro || die "lupdate failed"
+}