summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-07-17 13:58:15 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-07-17 13:58:15 +0000
commit3d61f0148bcbce2da0b41bf86869f7f1a96bac12 (patch)
tree5ada6552ef1f54b3caa964a6e3ed3c1979344f02 /media-sound/qmpdclient/qmpdclient-1.0.8.ebuild
parentStable on sparc wrt #185400 (diff)
downloadgentoo-2-3d61f0148bcbce2da0b41bf86869f7f1a96bac12.tar.gz
gentoo-2-3d61f0148bcbce2da0b41bf86869f7f1a96bac12.tar.bz2
gentoo-2-3d61f0148bcbce2da0b41bf86869f7f1a96bac12.zip
Added QMAKE_CC and QMAKE_LINK to qmake call. By Davide Pesavento <davidepesa at gmail.com> in bug #183593.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'media-sound/qmpdclient/qmpdclient-1.0.8.ebuild')
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.0.8.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-sound/qmpdclient/qmpdclient-1.0.8.ebuild b/media-sound/qmpdclient/qmpdclient-1.0.8.ebuild
index e15c1c086630..fbebcb58f6d2 100644
--- a/media-sound/qmpdclient/qmpdclient-1.0.8.ebuild
+++ b/media-sound/qmpdclient/qmpdclient-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.0.8.ebuild,v 1.2 2007/07/05 18:40:44 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.0.8.ebuild,v 1.3 2007/07/17 13:58:15 ticho Exp $
inherit eutils multilib qt4 toolchain-funcs
@@ -24,7 +24,7 @@ src_unpack() {
# Fix the install path
sed -i -e "s:PREFIX = /usr/local:PREFIX = /usr:" qmpdclient.pro \
- || die 'sed failed'
+ || die "sed failed"
}
src_compile() {
@@ -32,7 +32,9 @@ src_compile() {
qmake qmpdclient.pro \
QTDIR=/usr/$(get_libdir) \
QMAKE=/usr/bin/qmake \
+ QMAKE_CC=$(tc-getCC) \
QMAKE_CXX=$(tc-getCXX) \
+ QMAKE_LINK=$(tc-getCXX) \
QMAKE_TARGET=release \
QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \