summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-05 18:00:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-05 18:00:31 +0000
commit5fe57f7458c3c087cf479602a12c51fd54f1b600 (patch)
tree72ffb566d52d0555c2e01699a85d55b26543bead /media-sound/qtractor
parentremove unused version (diff)
downloadgentoo-2-5fe57f7458c3c087cf479602a12c51fd54f1b600.tar.gz
gentoo-2-5fe57f7458c3c087cf479602a12c51fd54f1b600.tar.bz2
gentoo-2-5fe57f7458c3c087cf479602a12c51fd54f1b600.zip
version bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'media-sound/qtractor')
-rw-r--r--media-sound/qtractor/ChangeLog7
-rw-r--r--media-sound/qtractor/qtractor-0.2.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-sound/qtractor/ChangeLog b/media-sound/qtractor/ChangeLog
index aefb6da1d774..50e4a66bac7c 100644
--- a/media-sound/qtractor/ChangeLog
+++ b/media-sound/qtractor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qtractor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/ChangeLog,v 1.12 2008/08/29 20:33:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/ChangeLog,v 1.13 2008/10/05 18:00:31 aballier Exp $
+
+*qtractor-0.2.2 (05 Oct 2008)
+
+ 05 Oct 2008; Alexis Ballier <aballier@gentoo.org> +qtractor-0.2.2.ebuild:
+ version bump
*qtractor-0.2.1 (29 Aug 2008)
diff --git a/media-sound/qtractor/qtractor-0.2.2.ebuild b/media-sound/qtractor/qtractor-0.2.2.ebuild
new file mode 100644
index 000000000000..eff40f0688e8
--- /dev/null
+++ b/media-sound/qtractor/qtractor-0.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/qtractor-0.2.2.ebuild,v 1.1 2008/10/05 18:00:31 aballier Exp $
+
+EAPI=2
+
+inherit eutils qt4
+
+DESCRIPTION="Qtractor is an Audio/MIDI multi-track sequencer."
+HOMEPAGE="http://qtractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qtractor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug dssi libsamplerate mad osc rubberband vorbis sse"
+
+DEPEND="|| ( ( x11-libs/qt-core x11-libs/qt-gui )
+ =x11-libs/qt-4.3*:4 )
+ media-libs/alsa-lib[midi]
+ media-libs/libsndfile
+ media-sound/jack-audio-connection-kit
+ media-libs/ladspa-sdk
+ dssi? ( media-libs/dssi )
+ mad? ( media-libs/libmad )
+ libsamplerate? ( media-libs/libsamplerate )
+ osc? ( media-libs/liblo )
+ rubberband? ( media-libs/rubberband )
+ vorbis? ( media-libs/libvorbis )"
+
+src_configure() {
+ econf \
+ $(use_enable mad libmad) \
+ $(use_enable libsamplerate) \
+ $(use_enable vorbis libvorbis) \
+ $(use_enable osc liblo) \
+ --enable-ladspa \
+ $(use_enable dssi) \
+ $(use_enable rubberband librubberband) \
+ $(use_enable sse) \
+ $(use_enable debug) \
+ || die "econf failed"
+ eqmake4 qtractor.pro -o qtractor.mak
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO AUTHORS
+}