summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-24 20:51:24 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-08-24 20:51:24 +0000
commit9e492a7fc2c467a6cccc735f36f1fc39b24d81f8 (patch)
tree29d840bd069098edf1b9f879a3b5240cb8f2fc43 /media-sound/rhythmbox
parentFix for bug #280562 (diff)
downloadgentoo-2-9e492a7fc2c467a6cccc735f36f1fc39b24d81f8.tar.gz
gentoo-2-9e492a7fc2c467a6cccc735f36f1fc39b24d81f8.tar.bz2
gentoo-2-9e492a7fc2c467a6cccc735f36f1fc39b24d81f8.zip
Fix bug #282546, application crashed when song properties was opened, Patch import from upstream bug #590108. Clean up old revision.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog11
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.12.3-sigsegv-no-saveable-types.patch46
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.12.3-r2.ebuild (renamed from media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild)6
3 files changed, 61 insertions, 2 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index d36df0b83827..1977df65f3cd 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.155 2009/08/23 21:25:26 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.156 2009/08/24 20:51:23 mrpouet Exp $
+
+*rhythmbox-0.12.3-r2 (24 Aug 2009)
+
+ 24 Aug 2009; Romain Perier <mrpouet@gentoo.org>
+ -rhythmbox-0.12.3-r1.ebuild, +rhythmbox-0.12.3-r2.ebuild,
+ +files/rhythmbox-0.12.3-sigsegv-no-saveable-types.patch:
+ Fix bug #282546, application crashed when song properties was opened,
+ Patch import from upstream bug #590108.
+ Clean up old revision.
23 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org>
-rhythmbox-0.12.2-r1.ebuild, -files/rhythmbox-0.12.2-link-fixes.patch,
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.12.3-sigsegv-no-saveable-types.patch b/media-sound/rhythmbox/files/rhythmbox-0.12.3-sigsegv-no-saveable-types.patch
new file mode 100644
index 000000000000..8a2ede61f386
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.12.3-sigsegv-no-saveable-types.patch
@@ -0,0 +1,46 @@
+From 47a5f4753d1cfcd2bcc2de10daeaa7a71f598d5d Mon Sep 17 00:00:00 2001
+From: Jonathan Matthew <jonathan@d14n.org>
+Date: Wed, 29 Jul 2009 10:36:48 +0000
+Subject: metadata: don't crash if there are no saveable types (bug #590108)
+
+---
+diff --git a/metadata/rb-metadata-dbus-client.c b/metadata/rb-metadata-dbus-client.c
+index 8683446..30e1760 100644
+--- a/metadata/rb-metadata-dbus-client.c
++++ b/metadata/rb-metadata-dbus-client.c
+@@ -349,9 +349,13 @@ start_metadata_service (GError **error)
+ return FALSE;
+ }
+
+- saveable_type_list = g_strjoinv (", ", saveable_types);
+- rb_debug ("saveable types from metadata helper: %s", saveable_type_list);
+- g_free (saveable_type_list);
++ if (saveable_types != NULL) {
++ saveable_type_list = g_strjoinv (", ", saveable_types);
++ rb_debug ("saveable types from metadata helper: %s", saveable_type_list);
++ g_free (saveable_type_list);
++ } else {
++ rb_debug ("unable to save metadata for any file types");
++ }
+
+ if (message)
+ dbus_message_unref (message);
+@@ -704,10 +708,12 @@ rb_metadata_can_save (RBMetaData *md, const char *mimetype)
+ }
+ }
+
+- for (i = 0; saveable_types[i] != NULL; i++) {
+- if (g_str_equal (mimetype, saveable_types[i])) {
+- result = TRUE;
+- break;
++ if (saveable_types != NULL) {
++ for (i = 0; saveable_types[i] != NULL; i++) {
++ if (g_str_equal (mimetype, saveable_types[i])) {
++ result = TRUE;
++ break;
++ }
+ }
+ }
+
+--
+cgit v0.8.2
diff --git a/media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.12.3-r2.ebuild
index 1f7fbd5d905b..2e0353924f97 100644
--- a/media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.12.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild,v 1.2 2009/08/23 21:25:26 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.3-r2.ebuild,v 1.1 2009/08/24 20:51:23 mrpouet Exp $
EAPI="2"
WANT_AUTOMAKE="1.10"
@@ -132,6 +132,10 @@ src_prepare() {
# Fix last.fm plugin linking, bug #276972
epatch "${FILESDIR}/${P}-lastfm.patch"
+ # Fix bug #282546, don't crash if there are no saveable types
+ # (upstream bug #590108)
+ epatch "${FILESDIR}/${P}-sigsegv-no-saveable-types.patch"
+
intltoolize --force --copy --automake || die "intltoolize failed"
eautomake
}