summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-31 01:21:49 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-31 01:21:49 +0000
commit15b8c81f1e8a499a3023331841b9bb66fe3d6a97 (patch)
tree96b2cdb57d027d49f1aeb485876cd5ca37cefa04 /media-sound/sexypsf/sexypsf-0.4.5.ebuild
parentver bump (diff)
downloadgentoo-2-15b8c81f1e8a499a3023331841b9bb66fe3d6a97.tar.gz
gentoo-2-15b8c81f1e8a499a3023331841b9bb66fe3d6a97.tar.bz2
gentoo-2-15b8c81f1e8a499a3023331841b9bb66fe3d6a97.zip
Initial version. Player and xmms plugin for playstation music files.
Diffstat (limited to 'media-sound/sexypsf/sexypsf-0.4.5.ebuild')
-rw-r--r--media-sound/sexypsf/sexypsf-0.4.5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/sexypsf/sexypsf-0.4.5.ebuild b/media-sound/sexypsf/sexypsf-0.4.5.ebuild
new file mode 100644
index 000000000000..4851e0dccfd5
--- /dev/null
+++ b/media-sound/sexypsf/sexypsf-0.4.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sexypsf/sexypsf-0.4.5.ebuild,v 1.1 2004/03/31 01:21:49 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="sexyPSF is an open-source PSF (Playstation music) file player"
+
+MY_P="${PN}${PV//./}"
+HOMEPAGE="http://xodnizel.net/${PN}/"
+SRC_URI="http://xodnizel.net/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="xmms"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/zlib
+ xmms? ( media-sound/xmms )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ cd ${S}/Linux
+
+ # ppc and sparc are big-endian while all other keywords are
+ # little-endian (as far as I know)
+ use ppc64 || use ppc || use sparc && CPU="MSBFIRST" || CPU="LSBFIRST"
+
+ emake CPU="${CPU}" || die
+
+ if use xmms; then
+ cd ${S}/xmms
+ emake CPU="${CPU}" || die
+ fi
+}
+
+src_install() {
+ cd ${S}/Linux
+ dobin sexypsf
+
+ if use xmms; then
+ cd ${S}/xmms
+ exeinto `xmms-config --input-plugin-dir`
+ doexe libsexypsf.so
+ fi
+
+ dodoc ${S}/Docs/*
+}
+
+pkg_postinst() {
+ ewarn "The xmms plugin seems to be unstable. It does not play minipsf files,"
+ ewarn "but the command line works fine with them."
+}