summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-06 07:57:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-06 07:57:50 +0000
commit91ae6f69d445c161bcdc099a04872304b858d9c0 (patch)
tree2657d58ec5eff1592c01384488d66b84d20f8792 /media-sound/sndpeek
parentold (diff)
downloadgentoo-2-91ae6f69d445c161bcdc099a04872304b858d9c0.tar.gz
gentoo-2-91ae6f69d445c161bcdc099a04872304b858d9c0.tar.bz2
gentoo-2-91ae6f69d445c161bcdc099a04872304b858d9c0.zip
Fix building with GCC 4.4 and keyword ~amd64 wrt #272377.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/sndpeek')
-rw-r--r--media-sound/sndpeek/ChangeLog8
-rw-r--r--media-sound/sndpeek/files/sndpeek-1.3-gcc-4.4.patch11
-rw-r--r--media-sound/sndpeek/sndpeek-1.3-r1.ebuild22
3 files changed, 28 insertions, 13 deletions
diff --git a/media-sound/sndpeek/ChangeLog b/media-sound/sndpeek/ChangeLog
index d9966907e689..a4d7609ae0ee 100644
--- a/media-sound/sndpeek/ChangeLog
+++ b/media-sound/sndpeek/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/sndpeek
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sndpeek/ChangeLog,v 1.3 2008/06/28 10:45:42 cedk Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sndpeek/ChangeLog,v 1.4 2009/06/06 07:57:49 ssuominen Exp $
+
+ 06 Jun 2009; Samuli Suominen <ssuominen@gentoo.org> sndpeek-1.3-r1.ebuild,
+ +files/sndpeek-1.3-gcc-4.4.patch:
+ Fix building with GCC 4.4 and keyword ~amd64 wrt #272377.
*sndpeek-1.3-r1 (28 Jun 2008)
diff --git a/media-sound/sndpeek/files/sndpeek-1.3-gcc-4.4.patch b/media-sound/sndpeek/files/sndpeek-1.3-gcc-4.4.patch
new file mode 100644
index 000000000000..d92bcdddf3b2
--- /dev/null
+++ b/media-sound/sndpeek/files/sndpeek-1.3-gcc-4.4.patch
@@ -0,0 +1,11 @@
+diff -ur sndpeek-1.3.orig/src/sndpeek/RtAudio.cpp sndpeek-1.3/src/sndpeek/RtAudio.cpp
+--- sndpeek-1.3.orig/src/sndpeek/RtAudio.cpp 2006-01-14 01:38:54.000000000 +0200
++++ sndpeek-1.3/src/sndpeek/RtAudio.cpp 2009-06-06 10:58:48.000000000 +0300
+@@ -40,6 +40,7 @@
+ // RtAudio: Version 3.0.1, 22 March 2004
+
+ #include "RtAudio.h"
++#include <cstdio>
+ #include <iostream>
+
+ // Static variable definitions.
diff --git a/media-sound/sndpeek/sndpeek-1.3-r1.ebuild b/media-sound/sndpeek/sndpeek-1.3-r1.ebuild
index b6ca0e73b1f1..46e8d03e80d0 100644
--- a/media-sound/sndpeek/sndpeek-1.3-r1.ebuild
+++ b/media-sound/sndpeek/sndpeek-1.3-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sndpeek/sndpeek-1.3-r1.ebuild,v 1.1 2008/06/28 10:45:42 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sndpeek/sndpeek-1.3-r1.ebuild,v 1.2 2009/06/06 07:57:49 ssuominen Exp $
+EAPI=2
inherit eutils toolchain-funcs
DESCRIPTION="real-time audio visualization"
@@ -10,7 +11,7 @@ SRC_URI="http://soundlab.cs.princeton.edu/software/${PN}/files/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="oss jack alsa"
DEPEND="virtual/glut
@@ -23,11 +24,10 @@ DEPEND="virtual/glut
alsa? ( media-libs/alsa-lib )"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-makefile.patch"
- epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.4.patch
}
pkg_setup() {
@@ -55,11 +55,11 @@ src_compile() {
backend="oss"
fi
einfo "Compiling against ${backend}"
- emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) || die "emake failed"
}
src_install() {
- dobin src/sndpeek/sndpeek
-
+ dobin src/sndpeek/sndpeek || die "dobin failed"
dodoc AUTHORS README THANKS TODO VERSIONS
}