summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-06-28 23:16:25 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-06-28 23:16:25 +0000
commit000c61361a72855647afe1f4c3e7416efff1f16f (patch)
treefdac53b6f8b7a08c53bacf0190480ee7f87d80da /media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
parentVersion bump, remove old. (diff)
downloadgentoo-2-000c61361a72855647afe1f4c3e7416efff1f16f.tar.gz
gentoo-2-000c61361a72855647afe1f4c3e7416efff1f16f.tar.bz2
gentoo-2-000c61361a72855647afe1f4c3e7416efff1f16f.zip
Version bump and patch by me to fix compilation with gcc-4.3 and 4.4; bug #251259
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'media-sound/tapestrea/tapestrea-0.1.0.5.ebuild')
-rw-r--r--media-sound/tapestrea/tapestrea-0.1.0.5.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild b/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
new file mode 100644
index 000000000000..17988d33c5d1
--- /dev/null
+++ b/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild,v 1.1 2009/06/28 23:16:25 halcy0n Exp $
+
+EAPI="1"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Techniques + Paradigms for Expressive Synthesis, Transformation, Rendering of Environmental Audio"
+HOMEPAGE="http://taps.cs.princeton.edu/"
+SRC_URI="http://taps.cs.princeton.edu/release/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="oss jack +alsa doc"
+
+RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ media-libs/libsndfile
+ virtual/glut
+ virtual/opengl
+ virtual/glu
+ >=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_setup() {
+ local cnt=0
+ use jack && cnt="$((${cnt} + 1))"
+ use alsa && cnt="$((${cnt} + 1))"
+ use oss && cnt="$((${cnt} + 1))"
+ if [[ "${cnt}" -eq 0 ]] ; then
+ eerror "One of the following USE flags is needed: jack, alsa or oss"
+ die "Please set one audio engine type"
+ elif [[ "${cnt}" -ne 1 ]] ; then
+ ewarn "You have set ${P} to use multiple audio engine."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc44.patch"
+}
+
+src_compile() {
+ local backend
+ if use jack; then
+ backend="jack"
+ elif use alsa; then
+ backend="alsa"
+ elif use oss; then
+ backend="oss"
+ fi
+ einfo "Compiling against ${backend}"
+
+ # when compile with athlon or athlon-xp flags
+ # chuck crashes on removing a shred with a double free or corruption
+ # it happens in Chuck_VM_Stack::shutdown() on the line
+ # SAFE_DELETE_ARRAY( stack );
+ replace-cpu-flags athlon athlon-xp i686
+
+ cd "${S}/scripting/chuck-1.2.1.2/src"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
+
+ cd "${S}/src"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ dobin src/taps
+
+ dodoc AUTHORS BUGS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
+ if use doc; then
+ for dir in `find examples/* -type d -maxdepth 0`; do
+ docinto $dir
+ dodoc `find $dir/* -type f -maxdepth 0`
+ for dir2 in `find $dir/* -type d -maxdepth 0`; do
+ docinto $dir2
+ dodoc `find $dir2/* -type f -maxdepth 0`
+ done
+ done
+ docinto doc
+ dodoc doc/*
+ fi
+}