summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-03 17:36:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-03 17:36:03 +0000
commita7a6f6e968b0d076eb77db0bceda747fd2a5fdf1 (patch)
tree5c8c1b55085b6c51565741ef399e5841352ddc4b /media-sound/timidity-freepats/timidity-freepats-20060219.ebuild
parentAdd freepats to the choices of patchsets. (diff)
downloadgentoo-2-a7a6f6e968b0d076eb77db0bceda747fd2a5fdf1.tar.gz
gentoo-2-a7a6f6e968b0d076eb77db0bceda747fd2a5fdf1.tar.bz2
gentoo-2-a7a6f6e968b0d076eb77db0bceda747fd2a5fdf1.zip
Add freepats patchset, that is released under GPL-2 (plus exception similar to classpath's), not as complete as the other ones, but free.
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'media-sound/timidity-freepats/timidity-freepats-20060219.ebuild')
-rw-r--r--media-sound/timidity-freepats/timidity-freepats-20060219.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/timidity-freepats/timidity-freepats-20060219.ebuild b/media-sound/timidity-freepats/timidity-freepats-20060219.ebuild
new file mode 100644
index 000000000000..30d1b29386cf
--- /dev/null
+++ b/media-sound/timidity-freepats/timidity-freepats-20060219.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-freepats/timidity-freepats-20060219.ebuild,v 1.1 2006/12/03 17:36:03 flameeyes Exp $
+
+IUSE=""
+
+MY_PN="${PN/timidity-/}"
+
+DESCRIPTION="Free and open set of instrument patches"
+HOMEPAGE="http://freepats.opensrc.org/"
+SRC_URI="${HOMEPAGE}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+# Only installs datafiles
+RESTRICT="binchecks strip"
+
+# These can be used for libmodplug too, so don't depend on timidity++
+DEPEND=">=app-admin/eselect-timidity-20061203"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_install() {
+ insinto /usr/share/timidity/${MY_PN}
+
+ newins freepats.cfg timidity.cfg
+ doins -r Drum_000 Tone_000
+
+ dodoc README
+}
+
+pkg_postinst() {
+ eselect timidity update --global --if-unset
+}