summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 16:15:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 16:15:58 +0000
commit17325d042d45585c6f6b36a6cf2e8bdae2f42b99 (patch)
tree6e76daaf245cea695dec3e897f3189eeecbb48e6 /media-sound/tk707
parentEbuild cleanup, fix depend, and CC/CFLAGS handling, closes bug #246819 (diff)
downloadgentoo-2-17325d042d45585c6f6b36a6cf2e8bdae2f42b99.tar.gz
gentoo-2-17325d042d45585c6f6b36a6cf2e8bdae2f42b99.tar.bz2
gentoo-2-17325d042d45585c6f6b36a6cf2e8bdae2f42b99.zip
Fix build with forced asneeded, bug #247866, honour ldflags, dont prestrip files
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-sound/tk707')
-rw-r--r--media-sound/tk707/ChangeLog8
-rw-r--r--media-sound/tk707/files/tk707-0.8-asneeded.patch15
-rw-r--r--media-sound/tk707/files/tk707-0.8-nostrip.patch13
-rw-r--r--media-sound/tk707/tk707-0.8-r1.ebuild4
4 files changed, 38 insertions, 2 deletions
diff --git a/media-sound/tk707/ChangeLog b/media-sound/tk707/ChangeLog
index 2a4a40cb8fcd..0be482f98972 100644
--- a/media-sound/tk707/ChangeLog
+++ b/media-sound/tk707/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/tk707
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/ChangeLog,v 1.9 2008/12/19 16:04:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/ChangeLog,v 1.10 2008/12/19 16:15:58 aballier Exp $
+
+ 19 Dec 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/tk707-0.8-asneeded.patch, +files/tk707-0.8-nostrip.patch,
+ tk707-0.8-r1.ebuild:
+ Fix build with forced asneeded, bug #247866, honour ldflags, dont prestrip
+ files
19 Dec 2008; Alexis Ballier <aballier@gentoo.org> tk707-0.8-r1.ebuild:
remove useless configure switches, use emake, drop redundant DEPs
diff --git a/media-sound/tk707/files/tk707-0.8-asneeded.patch b/media-sound/tk707/files/tk707-0.8-asneeded.patch
new file mode 100644
index 000000000000..a7833fd31d32
--- /dev/null
+++ b/media-sound/tk707/files/tk707-0.8-asneeded.patch
@@ -0,0 +1,15 @@
+Index: tk707-0.8/Makefile.am
+===================================================================
+--- tk707-0.8.orig/Makefile.am
++++ tk707-0.8/Makefile.am
+@@ -42,8 +42,8 @@ tk707tcl_SOURCES = util707.c util707.h
+ tcl2c_SOURCES = tcl2c.c
+ texi2help_SOURCES = texi2help.l
+
+-tk707bin_LDFLAGS = $(ALSA_LIBS) $(TCLTK_LIBS) $(X_LIBS)
+-tk707tcl_LDFLAGS = $(ALSA_LIBS) $(TCLTK_LIBS) $(X_LIBS)
++tk707bin_LDADD = $(ALSA_LIBS) $(TCLTK_LIBS) $(X_LIBS)
++tk707tcl_LDADD = $(ALSA_LIBS) $(TCLTK_LIBS) $(X_LIBS)
+ INCLUDES = $(ALSA_CFLAGS) $(TCLTK_CFLAGS) $(X_CFLAGS)
+
+ pkgdata_DATA = 707.map 727.map 7b7.map 7c7.map \
diff --git a/media-sound/tk707/files/tk707-0.8-nostrip.patch b/media-sound/tk707/files/tk707-0.8-nostrip.patch
new file mode 100644
index 000000000000..f0c35fa89702
--- /dev/null
+++ b/media-sound/tk707/files/tk707-0.8-nostrip.patch
@@ -0,0 +1,13 @@
+Index: tk707-0.8/Makefile.am
+===================================================================
+--- tk707-0.8.orig/Makefile.am
++++ tk707-0.8/Makefile.am
+@@ -191,7 +191,7 @@ $(srcdir)/texi2help.c: texi2help.l
+
+ install-exec-local: tk707bin tk707.sh
+ $(mkinstalldirs) $(DESTDIR)$(bindir)
+- sh $(srcdir)/install-sh -s -c tk707bin $(DESTDIR)$(bindir)/tk707bin
++ sh $(srcdir)/install-sh -c tk707bin $(DESTDIR)$(bindir)/tk707bin
+ $(INSTALL_SCRIPT) tk707.sh $(DESTDIR)$(bindir)/tk707
+
+ uninstall-local:
diff --git a/media-sound/tk707/tk707-0.8-r1.ebuild b/media-sound/tk707/tk707-0.8-r1.ebuild
index 1b5627db5dfe..359eb1dca0ca 100644
--- a/media-sound/tk707/tk707-0.8-r1.ebuild
+++ b/media-sound/tk707/tk707-0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/tk707-0.8-r1.ebuild,v 1.7 2008/12/19 16:04:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/tk707-0.8-r1.ebuild,v 1.8 2008/12/19 16:15:58 aballier Exp $
inherit eutils autotools
@@ -25,6 +25,8 @@ src_unpack() {
EPATCH_SOURCE=${S} epatch ${P}-*.patch
cd "${S}"
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ epatch "${FILESDIR}/${P}-nostrip.patch"
eautoreconf
}