summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-08-13 21:58:37 +0000
committerCédric Krier <cedk@gentoo.org>2009-08-13 21:58:37 +0000
commit2a71075385e5bfb74eb49e30b5b6e740a217648e (patch)
treea3b6bbf868686581e647272b74b230983c6720d5 /media-sound
parentAdd multi-backend support, add default USE flag for bug #254738 and fix CFLAG... (diff)
downloadgentoo-2-2a71075385e5bfb74eb49e30b5b6e740a217648e.tar.gz
gentoo-2-2a71075385e5bfb74eb49e30b5b6e740a217648e.tar.bz2
gentoo-2-2a71075385e5bfb74eb49e30b5b6e740a217648e.zip
Remove old
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audicle/ChangeLog5
-rw-r--r--media-sound/audicle/audicle-1.0.0.6.ebuild84
2 files changed, 4 insertions, 85 deletions
diff --git a/media-sound/audicle/ChangeLog b/media-sound/audicle/ChangeLog
index f68a33ba9dd5..4a63e088aa64 100644
--- a/media-sound/audicle/ChangeLog
+++ b/media-sound/audicle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/audicle
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/ChangeLog,v 1.4 2009/08/13 21:57:52 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/ChangeLog,v 1.5 2009/08/13 21:58:37 cedk Exp $
+
+ 13 Aug 2009; Cédric Krier <cedk@gentoo.org> -audicle-1.0.0.6.ebuild:
+ Remove old
*audicle-1.0.0.6-r1 (13 Aug 2009)
diff --git a/media-sound/audicle/audicle-1.0.0.6.ebuild b/media-sound/audicle/audicle-1.0.0.6.ebuild
deleted file mode 100644
index bc17cbd830ca..000000000000
--- a/media-sound/audicle/audicle-1.0.0.6.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/audicle-1.0.0.6.ebuild,v 1.3 2009/06/28 21:28:03 halcy0n Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="A Context-sensitive, On-the-fly Audio Programming Environ/mentality"
-HOMEPAGE="http://audicle.cs.princeton.edu/"
-SRC_URI="http://audicle.cs.princeton.edu/release/files/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="oss jack alsa truetype"
-
-RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
- alsa? ( >=media-libs/alsa-lib-0.9 )
- media-libs/libsndfile
- virtual/glut
- virtual/opengl
- virtual/glu
- >=x11-libs/gtk+-2
- truetype? ( media-libs/ftgl
- media-fonts/corefonts )"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-font.patch"
- epatch "${FILESDIR}/${P}-hid-smc.patch"
- epatch "${FILESDIR}/${P}-gcc43.patch"
-
- sed -i \
- -e "s@../ftgl_lib/FTGL/include@/usr/include/FTGL@" \
- -e "s@../ftgl_lib/FTGL/mac/build@/usr/lib@" \
- src/makefile.{alsa,jack,oss} || die "sed failed"
-}
-
-pkg_setup() {
- local cnt=0
- use jack && cnt="$((${cnt} + 1))"
- use alsa && cnt="$((${cnt} + 1))"
- use oss && cnt="$((${cnt} + 1))"
- if [[ "${cnt}" -eq 0 ]]; then
- eerror "One of the following USE flags is needed: jack, alsa or oss"
- die "Please set one audio engine type"
- elif [[ "${cnt}" -ne 1 ]]; then
- ewarn "You have set ${P} to use multiple audio engine."
- fi
-}
-
-src_compile() {
- local backend
- if use jack; then
- backend="jack"
- elif use alsa; then
- backend="alsa"
- elif use oss; then
- backend="oss"
- fi
- einfo "Compiling against ${backend}"
- local config
- use truetype && config="USE_FREETYPE_LIBS=1"
-
- # when compile with athlon or athlon-xp flags
- # audicle crashes on removing a shred with a double free or corruption
- # it happens in Chuck_VM_Stack::shutdown() on the line
- # SAFE_DELETE_ARRAY( stack );
- replace-cpu-flags athlon athlon-xp i686
-
- cd "${S}/src"
- emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) LEX=flex \
- YACC=bison $config || die "emake failed"
-}
-
-src_install() {
- dobin src/audicle
-
- dodoc AUTHORS PROGRAMMER README THANKS TODO VERSIONS
-}